#32461 [Fbk]: MySQL Extension Segmentation Fault

From: Date: Sat, 26 Mar 2005 18:11:26 +0000
Subject: #32461 [Fbk]: MySQL Extension Segmentation Fault
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-75893@lists.php.net to get a copy of this message
ID: 32461 Updated by: derick@php.net Reported By: nofulfillment at numbinside dot net Status: Feedback Bug Type: MySQL related Operating System: GNU/Linux (Slackware 10.1) PHP Version: 5.0.3 New Comment: Actually - you should *never* run autoconf yourself... Previous Comments: ------------------------------------------------------------------------ [2005-03-26 19:08:06] tony2001@php.net You don't need to run anything except for ./configure && make & make install when you're building packages from php.net. The error you get means that you're using unsupported version of autoconf (the supported one is 2.13). ------------------------------------------------------------------------ [2005-03-26 18:55:53] nofulfillment at numbinside dot net Please excuse the ignorance, but how would I install this package. I tried to run autoconf to generate a ./configure file, but it gave warnings and when I ran the result, it failed. User@Server:~/src/php5-STABLE-200503261730# autoconf configure.in:150: warning: AC_PROG_LEX invoked multiple times autoconf/programs.m4:438: AC_DECL_YYTEXT is expanded from... configure.in:150: the top level configure.in:77: error: possibly undefined macro: AC_MSG_ERROR If this token and others are legitimate, please use m4_pattern_allow. See the Autoconf documentation. configure.in:141: error: possibly undefined macro: AC_MSG_CHECKING configure.in:146: error: possibly undefined macro: AC_MSG_RESULT configure.in:194: error: possibly undefined macro: AC_DEFINE configure.in:209: error: possibly undefined macro: AC_DEFINE_UNQUOTED configure.in:484: error: possibly undefined macro: AC_TRY_LINK configure.in:1218: error: possibly undefined macro: AC_PROG_LIBTOOL User@Server:~/src/php5-STABLE-200503261730# `cat /home/AnotherUser/phpconfig.txt` ./configure: line 42: syntax error near unexpected token `Running' ./configure: line 42: `PHP_CONFIGURE_PART(Running system checks)' The phpconfig.txt file has a known-to-be-valid ./configure statement in there, that was used to compile both the 4.3.10 and 5.0.3 releases. Thanks again. :) -Wes ------------------------------------------------------------------------ [2005-03-26 07:48:11] tony2001@php.net Please try using this CVS snapshot: http://snaps.php.net/php5-STABLE-latest.tar.gz For Windows: http://snaps.php.net/win32/php5.0-win32-latest.zip ------------------------------------------------------------------------ [2005-03-26 05:10:33] nofulfillment at numbinside dot net Description: ------------ I'm working with phpMyAdmin (irrelivent, but aids in understanding), and I had the MYSQL_SOCKET file configured wrong. PHP's MySQL extension was creating a Segmentation fault in that it was trying to read a non-existant file. My configure line, I do not believe to be relavent, but I have included it anyways. (Along with some other details from phpinfo()) System: Linux NcFTestServer-Linux 2.4.29-grsec #7 SMP Thu Feb 3 18:41:23 PST 2005 i686 Build Date: Dec 23 2004 15:48:45 Configure Command: './configure' '--prefix=/usr' '--disable-static' '--with-apxs=/usr/sbin/apxs' '--sysconfdir=/etc' '--enable-discard-path' '--with-config-file-path=/etc/apache' '--enable-safe-mode' '--with-openssl' '--with-mhash' '--enable-bcmath' '--with-bz2' '--with-pic' '--enable-calendar' '--enable-ctype' '--with-gdbm' '--with-db3' '--enable-dbase' '--enable-ftp' '--with-iconv' '--with-exif' '--with-gd' '--enable-gd-native-ttf' '--with-jpeg-dir=/usr' '--with-png' '--with-gmp' '--with-mysql' '--with-gettext=shared,/usr' '--with-expat-dir=/usr' '--with-xml' '--enable-wddx' '--with-mm=/usr' '--enable-trans-sid' '--enable-shmop' '--enable-sockets' '--with-regex=php' '--enable-sysvsem' '--enable-sysvshm' '--enable-yp' '--enable-memory-limit' '--with-tsrm-pthreads' '--enable-shared' '--disable-debug' '--with-zlib=/usr' Using php.ini-recommended, although this does NOT change why it's failing (tried falling back to -dist, but had the same problem). GDB backtrace is mostly irrelievent, and it was NOT built with debugging symbols. I believe that this can be solved by checking to see if the file exists. Reproduce code: --------------- Try connecting to MySQL using a non-existant local socket file. (i.e., /tmp/non-exist.sock) Expected result: ---------------- When trying to run phpMyAdmin, I was expecting to see the login page. Actual result: -------------- Output from Bash trying to WGET it to see what happens: user@computer:/# wget http://server/phpMyAdmin_folder/index.php --11:35:05-- http://server/phpMyAdmin_folder/index.php Resolving server... done. Connecting to server[i.p.v.4]:80... connected. HTTP request sent, awaiting response... 11:35:06 ERROR -1: No data received. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=32461&edit=1

« previous php.bugs (#75893) next »