#32613 [NEW]: php --version fails with snmpapp.conf access error

From: Date: Wed, 06 Apr 2005 21:50:42 +0000
Subject: #32613 [NEW]: php --version fails with snmpapp.conf access error
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-76457@lists.php.net to get a copy of this message
From:             ric at arizona dot edu
Operating system: Solaris 8
PHP version:      4.3.11
PHP Bug Type:     SNMP related
Bug description:  php --version fails with snmpapp.conf access error

Description:
------------
Build environment is Solaris 8 with net-snmp5.1.

I built php 4.3.11 with
 ./configure --with-mysql=/usr/local  \
     --with-openssl=/usr/local/ssl --with-ldap \
     --with-apxs=/private/apache/bin/apxs --with-xml --with-pspell \
     --with-snmp --with-zlib
    make

The build completed normally, but when I then run
 $ /dfs/src/solaris/php-4.3.11/sapi/cli/php--version
I get
 PHP 4.3.11 (cli) (built: Apr  6 2005 11:12:09)
 Copyright (c) 1997-2004 The PHP Group
 Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
 Cannot rename /var/net-snmp/snmpapp.conf to /var/net-snmp/snmpapp.0.conf
 Cannot unlink /var/net-snmp/snmpapp.conf
 read_config_store open failure on /var/net-snmp/snmpapp.conf
 read_config_store open failure on /var/net-snmp/snmpapp.conf
 read_config_store open failure on /var/net-snmp/snmpapp.conf

On the same computer with the same environment, I built
php 4.3.10, and it produces no such errors, viz:
 $ /dfs/src/solaris/php-4.3.10/sapi/cli/php --version
 PHP 4.3.10 (cli) (built: Apr  6 2005 14:30:39)
 Copyright (c) 1997-2004 The PHP Group
 Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

4.3.11 appears to need write access to /var/snmp to 
be able to rename files and read/write access to snmpapp.conf.   Short of
making /var/snmp world write,
and snmpapp.conf world write is there a way to restore
the 4.3.10 behvior which doesn't even require the
existance of /var/net-snmp?

Thanks
Ric Anderson (ric@arizona.edu)

Reproduce code:
---------------
Configure and build 4.3.11 --with-snmp, and then try
to run
 sapi/cli/php --version
as a mortal (non-root) user.

Expected result:
----------------
I expect to see the version info e.g.
 PHP 4.3.11 (cli) (built: Apr  6 2005 11:12:09)
 Copyright (c) 1997-2004 The PHP Group
 Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

Actual result:
--------------
 PHP 4.3.11 (cli) (built: Apr  6 2005 11:12:09)
 Copyright (c) 1997-2004 The PHP Group
 Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
 Cannot rename /var/net-snmp/snmpapp.conf to /var/net-snmp/snmpapp.0.conf
 Cannot unlink /var/net-snmp/snmpapp.conf
 read_config_store open failure on /var/net-snmp/snmpapp.conf
 read_config_store open failure on /var/net-snmp/snmpapp.conf
 read_config_store open failure on /var/net-snmp/snmpapp.conf

-- 
Edit bug report at http://bugs.php.net/?id=32613&edit=1
-- 
Try a CVS snapshot (php4):   http://bugs.php.net/fix.php?id=32613&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=32613&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=32613&r=trysnapshot51
Fixed in CVS:                http://bugs.php.net/fix.php?id=32613&r=fixedcvs
Fixed in release:            http://bugs.php.net/fix.php?id=32613&r=alreadyfixed
Need backtrace:              http://bugs.php.net/fix.php?id=32613&r=needtrace
Need Reproduce Script:       http://bugs.php.net/fix.php?id=32613&r=needscript
Try newer version:           http://bugs.php.net/fix.php?id=32613&r=oldversion
Not developer issue:         http://bugs.php.net/fix.php?id=32613&r=support
Expected behavior:           http://bugs.php.net/fix.php?id=32613&r=notwrong
Not enough info:             http://bugs.php.net/fix.php?id=32613&r=notenoughinfo
Submitted twice:             http://bugs.php.net/fix.php?id=32613&r=submittedtwice
register_globals:            http://bugs.php.net/fix.php?id=32613&r=globals
PHP 3 support discontinued:  http://bugs.php.net/fix.php?id=32613&r=php3
Daylight Savings:            http://bugs.php.net/fix.php?id=32613&r=dst
IIS Stability:               http://bugs.php.net/fix.php?id=32613&r=isapi
Install GNU Sed:             http://bugs.php.net/fix.php?id=32613&r=gnused
Floating point limitations:  http://bugs.php.net/fix.php?id=32613&r=float
No Zend Extensions:          http://bugs.php.net/fix.php?id=32613&r=nozend
MySQL Configuration Error:   http://bugs.php.net/fix.php?id=32613&r=mysqlcfg


Thread (8 messages)

« previous php.bugs (#76457) next »