#28979 [Com]: When trying start up web server, php4_init makes web server crash
| From: | alton at shocknetwork dot com | Date: | Sat, 09 Apr 2005 22:50:39 +0000 |
| Subject: | #28979 [Com]: When trying start up web server, php4_init makes web server crash | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-76580@lists.php.net to get a copy of this message | ||
ID: 28979
Comment by: alton at shocknetwork dot com
Reported By: ryuan at buchanan dot com
Status: No Feedback
Bug Type: iPlanet related
Operating System: AIX 5.1
PHP Version: 4.3.6
New Comment:
I get the same problem with the CVS version php4-STABLE-200504092037/
on Trustix Secure Linux 2.1.
Previous Comments:
------------------------------------------------------------------------
[2005-01-19 01:00:05] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2005-01-11 06:44:54] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
------------------------------------------------------------------------
[2004-06-30 22:02:23] ryuan at buchanan dot com
Description:
------------
I've installed PHP 4.3.4 on AIX 5.1. The webserver is SunONE6.1SP1. The
libphp4.so is created successfully.
PHP works well from command line. I've done the configurations of
SunONE web server (magnus.conf, magnus.conf, mime.types).
In magnus.conf file, if I take out the line of
"Init fn=php4_init LateInit="yes" errorString="Failed to initialize
PHP!""
the web server can start up successfully.
But with the line "Init fn=php4_init ..", the web server crash with a
300MB core file in config directory.
The errors log file has thousands lines error message. I paste the very
last lines here:
[30/Jun/2004:18:14:19] warning (24232): CORE3283: stderr: 3CLTEXTCLASS
sun/misc/URLClassPath$5(0x41F73F08) [30/Jun/2004:18:14:19] warning
(24232): CORE3283: stderr: 3CLTEXTCLASS
sun/misc/Launcher$2(0x41F72158) [30/Jun/2004:18:14:19] warning
(24232): CORE3283: stderr: 3CLTEXTCLASS
sun/misc/Launcher$Factory(0x4093FBD8) [30/Jun/2004:18:14:19] warning
(24232): CORE3283: stderr: 3CLTEXTCLASS
java/lang/ref/PhantomReference(0x4093B958) [30/Jun/2004:18:14:19]
warning (24232): CORE3283: stderr: 3CLTEXTCLASS
java/security/PrivilegedAction(0x409362A8) [30/Jun/2004:18:14:19]
warning (24232): CORE3283: stderr: 3CLTEXTCLASS
java/util/Hashtable$EntrySet(0x41F7A528) [30/Jun/2004:18:14:19]
warning (24232): CORE3283: stderr: 3CLTEXTCLASS
java/io/Writer(0x4093ED98) [30/Jun/2004:18:14:19] warning (24232):
CORE3283: stderr: 3CLTEXTCLASS sun/io/Converters(0x4093DA98)
[30/Jun/2004:18:14:19] warning (24232): CORE3283: stderr: 3CLTEXTCLASS
java/lang/Integer(0x409382B8) [30/Jun/2004:18:14:19] catastrophe
(24232): CORE3260: Server crash detected (signal SIGSEGV)
[30/Jun/2004:18:14:19] warning (24232): CORE3283: stderr: NULL
------------------------------------------------------------------------
[30/Jun/2004:18:14:19] info (24232): CORE3261: Crash occurred in NSAPI
SAF php4_init [30/Jun/2004:18:14:19] warning (24232): CORE3283:
stderr: 0SECTION Javadump End section
Thanks in advance.
Expected result:
----------------
I expect to see the web server start up, as I tested the same PHP
version on my Solaris platform. No problem.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=28979&edit=1