Bug #15333 Updated: strndup access violation

From: Date: Tue, 14 May 2002 21:08:08 +0000
Subject: Bug #15333 Updated: strndup access violation
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-7680@lists.php.net to get a copy of this message
ID: 15333 Updated by: mdavis@cbsh.com Reported By: david@harksystems.com Status: Critical Bug Type: IIS related Operating System: Windows 2000 Pro PHP Version: 4.2.0 RC2 New Comment: Any update to this? Using PHP 2.0 Gold and still haveing this problm: php4ts!zend_strndup + 0x2B Previous Comments: ------------------------------------------------------------------------ [2002-05-10 04:22:01] stefan@digiconcept.net I've got the same configuration (win2k, iis5 and mssql via obdc) the machine want to run propperly and i've seen the same errors. now, php is configured in the applications mappings AND in the isapi filters (seen here somewhere as a hint). the site is "stored" in a fully configured virtual host ( assign ip-address, assigned host name, cache scripts etc etc). now, it runs stable without any of the strange errors described in the other postings. dont ask me why, i'm not really happy but so far it's a prove that the "mission impossible became reality" ;-) and it had cost me some hard days to make it true. btw: no zend encode or optimizer is installed ------------------------------------------------------------------------ [2002-04-23 18:35:20] develop@dnet.net how do I go about running 'tkill'? ------------------------------------------------------------------------ [2002-04-22 19:26:53] mail-php.net@kimihia.org.nz There is a tool called "tkill" / kill / tlist that will let you terminate processes. Get the PID from tlist or Task Manager and then run kill with the PID for the argument. inetinfo.exe will be running under a different user that Administrator does not have the power to kill the processes of, so using Task Manager to kill inetinfo.exe is a waste of time. ------------------------------------------------------------------------ [2002-04-21 06:32:35] llowry@novell.com I tried setting the app protection to 'Low (IIS Process)' and still get the error. And I tried killing inetinfo.exe and running the net stop commands from the command line, but Windows won't kill the process. This issue has turned out to be the biggest reason my I haven't embraced PHP yet -- because I hate rebooting my machine all of the time. I would love to hear of a workaround that works, and better yet, see a published fix. Any more ideas out there? ------------------------------------------------------------------------ [2002-04-17 15:19:04] marcus.b.brock@lmco.com I am getting this error with 4.2.0 RC2. I upgraded from 4.1.2 to 4.2.0 RC2 (both ISAPI) because 4.1.2 wasn't handling sessions correctly. I tried setting the app protection to 'Low (IIS Process)' and all I received were 'Invalid access to memory location' errors. PHP 4.2.0 RC2 (ISAPI) IIS5 Win2K Pro SP2 PIII 733MHz 384 MB RAM ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/15333 -- Edit this bug report at http://bugs.php.net/?id=15333&edit=1

« previous php.bugs (#7680) next »