Bug #16807 Updated: Sessions not working
| From: | keithauyeung at proactive dot com dot hk | Date: | Wed, 15 May 2002 09:10:47 +0000 |
| Subject: | Bug #16807 Updated: Sessions not working | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-7725@lists.php.net to get a copy of this message | ||
ID: 16807
Updated by: keithauyeung@proactive.com.hk
Reported By: martin_jones@bigfoot.com
Status: Open
Bug Type: Session related
Operating System: Windows 2000 SP2
PHP Version: 4.2.0
New Comment:
I think the following should help.
before the statement "<?php", is there any blank line above it?If yes,
delete the blank line and I think the problem will be solved. Hope this
help!!
Previous Comments:
------------------------------------------------------------------------
[2002-05-06 20:31:05] bs_php@infeer.com
Please check following:
I hade the same error because of spaces (or CR or TAB) *befor* the
first use of <?php !
Did you check that?
------------------------------------------------------------------------
[2002-05-05 18:23:00] dht1@totalise.co.uk
The error I receive (again, 4.2.0, IIS, and Win 2k) is that it is
unable to open the session folder.
May or may not be related, but I'm also experiencing problems with POST
variables.
David
------------------------------------------------------------------------
[2002-05-03 23:53:28] yohgaki@php.net
s/martin_jones@bigfoot.com/other mail addresses who comment on this/
------------------------------------------------------------------------
[2002-05-03 23:52:02] yohgaki@php.net
martin_jones@bigfoot.com
report is not about register globals issue. Please do not add any more
comments about register globals...
------------------------------------------------------------------------
[2002-05-01 20:24:11] chris@dvdplaza.com.au
I'm having a similar issue - every since switching to PHP 4.2 I've got
sh#tloads of viewers reporting login problems to our forums
(vBulletin), they keep getting prompted to login. Weird part is it's
not everyone, I and others have no problems at all. Reverting back to
PHP 4.1.x solves it, upgrading to PHP 4.2 brings it back.
register_globals is ON
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/16807
--
Edit this bug report at http://bugs.php.net/?id=16807&edit=1