#32687 [Csd->Bgs]: using -enable-zlib with --with-mysql causes possible mysql database corruption
| From: | tony2001@php.net | Date: | Wed, 13 Apr 2005 07:53:57 +0000 |
| Subject: | #32687 [Csd->Bgs]: using -enable-zlib with --with-mysql causes possible mysql database corruption | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-77454@lists.php.net to get a copy of this message | ||
ID: 32687
Updated by: tony2001@php.net
Reported By: elong1013 at comcast dot net
-Status: Closed
+Status: Bogus
Bug Type: MySQL related
Operating System: Fedora Core
PHP Version: 5.0.4
New Comment:
No bug -> bogus.
Previous Comments:
------------------------------------------------------------------------
[2005-04-13 02:13:08] elong1013 at comcast dot net
It has nothing to do with enable-zlib, i was mistaken.
------------------------------------------------------------------------
[2005-04-12 20:22:33] elong1013 at comcast dot net
Description:
------------
compiling php 5.04 with the '-enable-zlib' option along with
'--with-mysql' causes an 'Warning: mysql_query(): Unable to save result
set' query to appear on older versions of PHP accessing the same
database.
while preparing and testing an upgrade from the 4.3.9 version to the
5.0.4 version, i noticed that when i went back to my 4.3.9 version of
the compiled code, i got 'Warning: mysql_query(): Unable to save result
set' for any SQL command after the 5.0.4 version did any database
transactions.
i have 2 *seperate* machines with *identical* code accessing the same
database. Once the newer version is used, the older version does not
work again.
If i remove the -with-zlib compile directive from the 5.0.4 version,
both versions work together correctly.
once again, the error message only comes up on the OLDER version, but i
suspect the newer version changes something in the database that causes
the older version to fail.
here are my compiler directives
./configure
--prefix=/share/servers/php5
--with-mysql=/usr/lib/mysql
--with-apxs=/share/servers/httpd/bin/apxs
--with-openssl=/share/servers/libs/ssl
--with-jpeg-dir=/share/servers/libs/jpeg
--with-freetype-dir=/usr/lib
--with-gd=/share/servers/libs/gdlib
--with-mcrypt=/share/servers/libs/mcrypt
--enable-memory-limit
--with-config-file-path=/share/servers/php5/conf
-enable-zlib
--enable-ftp
I am running apache 1.3.33 w/ mod_ssl 2.8.22, here are the versions of
all libs that i use for my server.
gd-2.0.33
mm-1.3.1
php-5.0.4
jpeg-6b
mod_ssl-2.8.22-1.3.33
apache_1.3.33
libmcrypt-2.5.7
openssl-0.9.7e
libpng-1.2.7
Reproduce code:
---------------
do any database operation (SELECT, UPDATE, INSERT, DELETE) using PHP
5.0.4 with enable-zlib enabled and the php.ini setting
"zlib.output_compression = On"
database queries from a previous version of PHP will fail.
recompile without the -enable-zlib directive, and it will work
correctly (after you restore your database tables)
MAKE SURE YOU HAVE A BACKUP OF YOUR DATABASE if you try this.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=32687&edit=1