Bug #16769 Updated: Upgraded to Apache 2 with PHP not working
| From: | midori at quicksilver dot net dot nz | Date: | Fri, 17 May 2002 05:59:41 +0000 |
| Subject: | Bug #16769 Updated: Upgraded to Apache 2 with PHP not working | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-7894@lists.php.net to get a copy of this message | ||
ID: 16769
Updated by: midori@quicksilver.net.nz
Reported By: shirkdog2@hotmail.com
Status: Bogus
Bug Type: Apache2 related
Operating System: Windows 2000
PHP Version: 4.2.0
New Comment:
I've encountered the exact same problem on Win98. Apache 1.3.23
(Win32) runs PHP/4.2.0 fine, however, Apache 2.0.36 (Win32) crashes
with the following error:
----------------------------------------------
Syntax error on line 946 of (path_to_conf)/httpd.conf:
Cannot load (path_to_php)/sapi/php4apache.dll into server:
One of the library files needed to run this application cannot be
found.
----------------------------------------------
Previous Comments:
------------------------------------------------------------------------
[2002-05-03 11:17:17] orion_web35@hotmail.com
i tested php with Apache 2 on windows 2000 and dont work!
the entries of MODULES CONFIGS for the Apache 1.2.24 dont run in Apache
2.0.35
------------------------------------------------------------------------
[2002-04-23 16:12:16] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php
If you can provide more information, feel free to add it
to this bug and change the status back to "Open".
------------------------------------------------------------------------
[2002-04-23 15:53:21] shirkdog2@hotmail.com
Basically I tested PHP on the windows binary of apache 1.3.24 and
everything was great. However when going to apache 2.0.35, the same
entries that worked for apache 1.3.24 seem to cause errors. Apache
will only run when I comment out the MODULES CONFIGS in the httpd.conf.
I hope this is a known issue, I just do not want to reload the old
apache if you have a patch or different commands.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16769&edit=1