Bug #15333 Updated: strndup access violation
| From: | agustinchernitsky at hotmail dot com | Date: | Fri, 17 May 2002 17:37:42 +0000 |
| Subject: | Bug #15333 Updated: strndup access violation | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-7947@lists.php.net to get a copy of this message | ||
ID: 15333
Updated by: agustinchernitsky@hotmail.com
Reported By: david@harksystems.com
Status: Critical
Bug Type: IIS related
Operating System: Windows 2000 Pro
PHP Version: 4.2.0 RC2
New Comment:
Running PHP 4.2.1
Win2K Server with all Security Updates
Still getting the ISAPI module error. My event Log shows:
Event Type: Warning
Event Source: W3SVC
Event Category: None
Event ID: 36
Date: 17/05/2002
Time: 14:09:30
User: N/A
Computer: SERVER2
Description:
The server failed to load application '/LM/W3SVC/24/Root/admin'. The
error was 'The application called an interface that was marshalled for
a different thread.
'.
For additional information specific to this message please visit the
Microsoft Online Support site located at:
http://www.microsoft.com/contentredirect.asp.
Where /Root/admin is the virtual dir running PHP files.
Previous Comments:
------------------------------------------------------------------------
[2002-05-15 10:23:32] mdavis@cbsh.com
I beleive that is what it was being called when I downloaded it, maybe
I am mistaken.
Anyway I am now running php 4.2.1 and am having the same problem.
Windows 2000 Server
Stock PHP 4.2.1 install
Stock MySQL 3.29 install
Stock phpBB 2.0 install
------------------------------------------------
The HTTP server encountered an unhandled exception while processing the
ISAPI Application '
php4ts!zend_strndup + 0x2B
+ 0xA05E5983
------------------------------------------------
------------------------------------------------------------------------
[2002-05-14 17:46:39] rasmus@php.net
Uh, PHP 2.0 Gold? What the heck is that?
------------------------------------------------------------------------
[2002-05-14 17:08:08] mdavis@cbsh.com
Any update to this? Using PHP 2.0 Gold and still haveing this problm:
php4ts!zend_strndup + 0x2B
------------------------------------------------------------------------
[2002-05-10 04:22:01] stefan@digiconcept.net
I've got the same configuration (win2k, iis5 and mssql via obdc) the
machine want to run propperly and i've seen the same errors. now, php
is configured in the applications mappings AND in the isapi filters
(seen here somewhere as a hint). the site is "stored" in a fully
configured virtual host ( assign ip-address, assigned host name, cache
scripts etc etc). now, it runs stable without any of the strange errors
described in the other postings. dont ask me why, i'm not really happy
but so far it's a prove that the "mission impossible became reality"
;-) and it had cost me some hard days to make it true.
btw: no zend encode or optimizer is installed
------------------------------------------------------------------------
[2002-04-23 18:35:20] develop@dnet.net
how do I go about running 'tkill'?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/15333
--
Edit this bug report at http://bugs.php.net/?id=15333&edit=1