#33148 [Opn]: PHP Fails with apxs:Error: Command failed with rc=65536
ID: 33148
User updated by: scriptdaddy at gmail dot com
Reported By: scriptdaddy at gmail dot com
Status: Open
Bug Type: Compile Failure
Operating System: AIX 5.2 ML05
PHP Version: 4.3.11
New Comment:
Forgot to add the Apache Configuration Options.
Apache Configuration Options:
./configure --with-mpm=worker --enable-so --enable-mods-shared=most
--without-berkeley-db --enable-speling
Previous Comments:
------------------------------------------------------------------------
[2005-05-26 10:35:15] scriptdaddy at gmail dot com
Description:
------------
PHP fails with apxs:Error: Command failed with rc=65536; each and
everytime I compile it. Have replicated error on no-less than 10
occassions.
Error:
Installing PHP SAPI module: apache2handler
/usr/local/apache2/build/instdso.sh
SH_LIBTOOL='/usr/local/apache2/build/libtool' libphp4.la
/usr/local/apache2/modules
rm -f /usr/local/apache2/modules/libphp4.so
/usr/local/apache2/build/libtool --mode=install cp libphp4.la
/usr/local/apache2/modules/
cp .libs/libphp4.a /usr/local/apache2/modules/libphp4.a
cp .libs/libphp4.lai /usr/local/apache2/modules/libphp4.la
libtool: install: warning: remember to run `libtool --finish
/home/susteveo/apache/php4-STABLE-200505251440/libs'
chmod 755 /usr/local/apache2/modules/libphp4.so
chmod: /usr/local/apache2/modules/libphp4.so: A file or directory in
the path name does not exist.
apxs:Error: Command failed with rc=65536
.
make: 1254-004 The error code from the last command is 1.
Stop.
Using GNU GCC
Built on a IBM RS/6000 H70 using AIX 5.2 ML05 with 64 Bit Kernal
Enabled.
Using Apache 2.0.54, built with the following Configuration Options:
Same Error on PHP Versions: 4.XX, 5.XX and php4-STABLE-200505251440.
PHP built each time with following Configuration Options:
--disable-all --without-cli --with-apxs2=/usr/local/apache2/bin/apxs
Found that by copying the libphp4.so from .libs to
/usr/local/apache2/modules then Apache will serve PHP files, however
you have to manual configure the httpd.conf file and add the PHP
Directive.
Reproduce code:
---------------
./configure --disable-all --without-cli
--with-apxs2=/usr/local/apache2/bin/apxs
Expected result:
----------------
I expect PHP to compile successfully.
Actual result:
--------------
PHP does not compile successfully and following error produce each time
apxs:Error: Command failed with rc=65536.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=33148&edit=1
Thread (3 messages)