#33184 [Opn->Bgs]: odbc_exec(): SQL error: [IBM][CLI Driver][DB2/6000] SQL0954C Not enough storag

From: Date: Mon, 30 May 2005 13:29:27 +0000
Subject: #33184 [Opn->Bgs]: odbc_exec(): SQL error: [IBM][CLI Driver][DB2/6000] SQL0954C Not enough storag
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-79699@lists.php.net to get a copy of this message
ID: 33184 Updated by: sniper@php.net Reported By: brad_allgood at csgsystems dot com -Status: Open +Status: Bogus Bug Type: ODBC related Operating System: Windows XP PHP Version: 5.0.4 New Comment: SQL0954C Not enough storage is available in the application heap to process the statement. Explanation: All available memory for the application has been used. The statement cannot be processed. User Response: Terminate the application on receipt of this message. Increase the database configuration parameter (applheapsz) to allow a larger application heap. Previous Comments: ------------------------------------------------------------------------ [2005-05-30 15:17:32] brad_allgood at csgsystems dot com Description: ------------ Appears to be a resurface of bug id #16221 from 4.1.2 After doing between 50-182 query's to IBM DB2 7 on Windows 2000 (localhost) with this script: <? $connection = odbc_connect( "test","db2admin", "admin" ) or die("Unable to connect to SQL server"); } $result=odbc_exec($connection,"set current sqlid = 'DB2ADMIN'"); $counter=0; while ($counter <5000) { $query="select * from tms_user"; $result=odbc_exec($connection,$query); $temp=odbc_fetch_row ($result); echo "counter= $counter <br>"; odbc_free_result($result); odbc_close_all(); $counter++; } ?> ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=33184&edit=1

« previous php.bugs (#79699) next »