#33307 [Fbk]: PPC64 "R_PPC_REL24 relocation for symbol 'signal' out of range"
| From: | sniper@php.net | Date: | Sat, 11 Jun 2005 13:17:45 +0000 |
| Subject: | #33307 [Fbk]: PPC64 "R_PPC_REL24 relocation for symbol 'signal' out of range" | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-80150@lists.php.net to get a copy of this message | ||
ID: 33307
Updated by: sniper@php.net
Reported By: cjharrisr66t at yahoo dot com
Status: Feedback
Bug Type: Dynamic loading
Operating System: Yellowdog 4.0
PHP Version: 4.3.11
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php4-STABLE-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-STABLE-latest.zip
Get the snapshot and try what I suggested before.
Previous Comments:
------------------------------------------------------------------------
[2005-06-11 15:15:28] sniper@php.net
Try this:
# rm -f config.cache && ./configure --disable-all
--with-apxs2=/usr/sbin/apxs
# make clean && make
And copy the resulting .libs/libphp4.so to the correct place and try
starting Apache again. (stop && start)
------------------------------------------------------------------------
[2005-06-10 22:27:13] cjharrisr66t at yahoo dot com
Description:
------------
Running Kernel 2.6.10 on mac xserve G5, with the archecture ppc64
PHP 4.3.11 5.0.4 both compile/install well with out any errors.
Hers my configure line
--------------------------------------------------
./configure \
--build=powerpc-yellowdog-linux-gnu \
--target=ppc-yellowdog-linux-gnu --program-prefix= \ --prefix=/usr \
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin \
--sysconfdir=/etc --datadir=/usr/share \ --includedir=/usr/include\
--libdir=/usr/lib --libexecdir=/usr/libexec\
--localstatedir=/var\
--sharedstatedir=/usr/com --mandir=/usr/share/man\
--infodir=/usr/share/info --cache-file=../config.cache\
--with-config-file-path=/etc\ --with-config-file-scan-dir=/etc/php.d\
--enable-force-cgi-redirect --disable-debug --enable-pic\
--disable-rpath --enable-inline-optimization --with-bz2\
--with-db4=/usr --with-curl --with-exec-dir=/usr/bin\
--with-freetype-dir=/usr --with-png-dir=/usr --with-gd\
--enable-gd-native-ttf --without-gdbm --with-gettext\
--with-ncurses --with-gmp --with-iconv --with-jpeg-dir=/usr\
--with-openssl --with-png --with-pspell --with-regex=system\
--with-xml --with-expat-dir=/usr --with-dom=shared,/usr\
--with-dom-xslt=/usr --with-dom-exslt=/usr\ --with-xmlrpc=shared\
--with-pcre-regex --with-zlib --with-layout=GNU\ --enable-bcmath\
--enable-exif --enable-ftp --enable-magic-quotes\
--enable-safe-mode --enable-sockets --enable-sysvsem\
--enable-sysvshm --enable-track-vars --enable-trans-sid\
--enable-yp --enable-wddx --with-pear=/usr/share/pear\
--with-imap=shared --with-imap-ssl --with-kerberos\
--with-ldap=shared --with-mysql=/usr/local/mysql\
--enable-memory-limit --enable-bcmath --enable-shmop\
--enable-calendar --enable-dbx --enable-dio --enable-mcal\
--enable-mbstring=shared --enable-mbstr-enc-trans\
--enable-mbregex --with-apxs2=/usr/sbin/apxs
---------------
There have been no changes to my php.ini. The module has been added to
apache. But when trying to start apache version 2.0.51, it does not
start and in apaches error log i find the error.
Syntax error on line 6 of /etc/httpd/conf.d/php.conf:
Cannot load /usr/lib/httpd/modules/libphp4.so into server:
/usr/lib/httpd/module
s/libphp4.so: R_PPC_REL24 relocation at 0x0ddcf97c for symbol `signal'
out of range
I have seen that has been peolple with similar problems, in the far
past but, I'm not sure if this the same problem. Please let me know if
I can provide any more information.
-Cameorn
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=33307&edit=1