#33283 [Bgs]: Apache segfaults when attempting to use PDO
| From: | david dot prusak at copart dot com | Date: | Fri, 17 Jun 2005 16:25:31 +0000 |
| Subject: | #33283 [Bgs]: Apache segfaults when attempting to use PDO | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-80549@lists.php.net to get a copy of this message | ||
ID: 33283
User updated by: david dot prusak at copart dot com
Reported By: david dot prusak at copart dot com
Status: Bogus
Bug Type: PDO related
Operating System: *
PHP Version: 5.1-b1
New Comment:
First off, I have no idea when the php version changed to 5.1. I
reported it as 5.0.4. (had to check my email thread to verify) I had
assumed you wanted me to test this using 5.1 to see if that version had
a fix. I have no desire to actually use 5.1 at this time, (unless it
did work). I was hoping for a workaround in 5.0.4, but it looks like
there is no workaround. I do know the PECL libraries are
experiemental. I had only posted here to see if anyone knew of a
workaround or if it was a known issue.
Lastly, I'm learning this isn't the place to report such issues, so I'm
wondering where is the correct place to ask.
Previous Comments:
------------------------------------------------------------------------
[2005-06-17 00:56:26] sniper@php.net
First of all: You're reporting bug in 5.1-beta1, but you still talk
about using 5.0.x. Let's close this one as bogus.
Ask further support questions about how to compile/configure PHP
elsewhere.
------------------------------------------------------------------------
[2005-06-16 20:11:07] david dot prusak at copart dot com
Ahh communication :) I'm using 5.0.x using snaps.php.net for the PECL
extensions and the PHP builds. For Windows, I'm simply download and
installing. Loading the files via php.ini extensions.
For Solaris, I was using 5.0.x, Compiling PHP, then wget-ing the PDO
libraries from pecl.php.net. Compiling them and simply loading them in
the php.ini as libraries. The configure for that version of PHP
doesn't allow compiling PDO into php itself
I did download 5.1 for both Windows and Solaris.
On Windows, PDO loads fine, but the PDO_ODBC fails to load. Tells me
the module can't be found, but is is there.
On Solaris, I issued the following (reading 2 documents to use PDO_ODBC
with IBM_DB2 database and came up with the following configure:
./configure --with-apache2=../httpd-2.0.53 --prefix=/www/php
--with-gd=/usr/local --with-apxs2=/www/apache/bin/apxs
--with-config-file-path=/www/php/etc
--with-ibm-db2=/export/home/db2inst1/sqllib --with-pdo-odbc=ibm-db2
I get the same as before error when I try to issue the
--with-ibm-db2=/export/home/db2inst1/sqllib Without it, it compiles
and runs just fine, but without DB2 database connectivity.
--with-ibm-db2=/export/home/db2inst1/sqllib works just fine with 5.0.4
on http://www.php.net/downloads.php
------------------------------------------------------------------------
[2005-06-16 18:12:50] sniper@php.net
That is not the correct configure line to get PDO ODBC driver enabled,
try reading the ./configure --help output..
------------------------------------------------------------------------
[2005-06-14 02:06:09] david dot prusak at copart dot com
When I installed the link you provided on my Windows machine,
php/apache starts, but I get an error "Unable to load dynamic library
'C:\php\ext\php_pdo.dll' - the specified procedure could not be found.
This also occurs with php_pdo_odbc.dll
On my solaris machine, configure doesn't work. It's informing me that
the IBM_DB2 environment wasn't set, but I did run it and it is set.
./configure --with-apache2=../httpd-2.0.53 --prefix=/www/php
--with-mysql=/usr/local/mysql --with-gd=/usr/local
--with-apxs2=/www/apache/bin/apxs --with-config-file-path=/www/php/etc
--with-ibm-db2=/export/home/db2inst1/sqllib/
checking for Adabas support... no
checking for SAP DB support... no
checking for Solid support... no
checking for IBM DB2 support... ./configure: !: not found
no
configure: error:
build test failed. Please check the config.log for details.
You need to source your DB2 environment before running PHP configure:
# . $IBM_DB2/db2profile
configure:63159: checking for IBM DB2 support
configure:63230: gcc -o conftest -g -O2 -D_POSIX_PTHREAD_SEMANTICS
-R/usr/ucbl
ib -L/usr/ucblib -R/usr/local/lib/gcc/sparc-sun-solaris2.9/3.4.2
-L/usr/local/li
b/gcc/sparc-sun-solaris2.9/3.4.2 -R/usr/local/lib -L/usr/local/lib
-R/usr/local/
mysql/lib/mysql -L/usr/local/mysql/lib/mysql conftest.c
-L/export/home/db2inst1/sqllib//lib -ldb2
-lmysqlclient -lgd -lresolv -lm -ldl -lnsl -lsocket -lgcc -lxml2
-lz -lico
nv -lm -lsocket -lnsl -lxml2 -lz -liconv -lm -lsocket -lnsl 1>&5
configure: failed program was:
#line 63219 "configure"
#include "confdefs.h"
char SQLExecute();
int main() {
SQLExecute();
return 0;
}
--David
------------------------------------------------------------------------
[2005-06-10 18:39:15] david dot prusak at copart dot com
Well, I installed all this on my solaris box. Accessing the same page,
I get this in my apache error.log
[Fri Jun 10 09:29:03 2005] [notice] child pid 19516 exit signal
Segmentation fault (11)
Removing the "prepare" doesn't segfault apache. The behavior is
identical to the windows version.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/33283
--
Edit this bug report at http://bugs.php.net/?id=33283&edit=1