#33393 [Opn->Csd]: Configure dont detect db4.h outside standard pathes
ID: 33393
Updated by: sniper@php.net
Reported By: joerg@php.net
-Status: Open
+Status: Closed
Bug Type: Compile Failure
Operating System: IRIX 6.5.27
PHP Version: 5CVS-2005-06-18 (dev)
New Comment:
Who said those options accept such strings? =)
You have to use --enable-dba=shared to get a shared extension.
I added a note to the configure help about this.
(yes, I know it's inconsistent, not my fault..;)
Previous Comments:
------------------------------------------------------------------------
[2005-06-18 13:55:31] joerg@php.net
Description:
------------
Trying to compile php with db4 support as an shared extension wont work
and configure stops with the
..
checking for db4 major version... configure: error: Header contains
different version
..
message. This only happens when your headerfiles stay outside the
standard pathes *and* when using the 'shared' parameter.
It works like a charm with "--with-db4=/usr/nekoware"
Reproduce code:
---------------
Just run the configure
./configure --disable-all --with-db4=shared,/usr/nekoware
Expected result:
----------------
A propper configure run.
Actual result:
--------------
It stops with an error message
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=33393&edit=1
Thread (2 messages)