Bug #14594 Updated: Failed to compile/run when using Apache 2.x, unresolved symbols
| From: | stimpy at broekiemedia dot nl | Date: | Tue, 21 May 2002 20:08:10 +0000 |
| Subject: | Bug #14594 Updated: Failed to compile/run when using Apache 2.x, unresolved symbols | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-8120@lists.php.net to get a copy of this message | ||
ID: 14594
Updated by: stimpy@broekiemedia.nl
Reported By: juraj@bednar.sk
Status: Closed
Bug Type: Apache2 related
Operating System: FreeBSD 4.4-STABLE
PHP Version: 4.1.0
New Comment:
I'm using FreeBSD 4.5, Apache-2.0.35 for freebsd 4.5,
mysql-3.23.49-unknown-freebsdelf4.4-i386
I compiled with --with-mysql=/usr/local/mysql
--with-apxs2=/usr/local/apache2/bin/apxs
httpd.conf contains:
LoadModule php4_module modules/libphp4.so
AddType application/x-httpd-php .php
And also I get this error:
Failed to start apache :
Syntax error on line 217 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server:
/usr/local/apache2/modules/libphp4.so: Undefined symbol
"pthread_getspecific"
/usr/local/apache2/bin/apachectl start: httpd could not be started
Previous Comments:
------------------------------------------------------------------------
[2002-05-01 20:59:20] erkan.boga@netiq.com
I am using FreeBSD 4.5, Apache 2.0.35, GNU Pth 1.4.1 and PHP 4.2
I still get the error
Cannot load /prog/httpd/modules/libphp4.so into server:
/prog/httpd/modules/libphp4.so: Undefined symbol "pthread_getspecific"
./apachectl start: httpd could not be started
even if i have installed php 4.2 with the --with-tsrm-pth option
I have spend now 5 hours to find a solution but i couldn't find any
workaround...
any ideas ?
regards,
erkan
------------------------------------------------------------------------
[2002-04-19 11:36:18] aaron@php.net
This bug has already been fixed in the latest released version of
PHP, which you can download at http://www.php.net/downloads.php
The apache2filter is known to work with Apache 2.0.35
and either CVS HEAD or the 4.2.0 branch (or the latest
release candidate). Please report back if you have any
problems related to FreeBSD 4.x and these versions.
------------------------------------------------------------------------
[2002-04-15 16:30:23] klansman@arrakis.dhis.org
My installation worked!
installed gnu pth and used
--with-tsrm-pth=/usr/local/libs/pth in the configure script.
Note that this is warned in the end of the configure process.
[]
------------------------------------------------------------------------
[2002-04-15 09:36:17] josh@lokot.com
Same results on FreeBSD 4.2-RELEASE with Apache 2.0.35 / PHP 4.2.0RC4
------------------------------------------------------------------------
[2002-04-15 08:15:12] tino@tino.nl
Exactly the same error here.
FreeBSD 4.5 / Release
Apache 2.0.35
PHP 4.2.0RC4
Tried:
./configure --with-apache=/usr/local/apache2/bin/apxs --with-tsrm-pth
Didn't work:
./apachectl configtest
Syntax error on line 217 of /usr/local/apache2/conf/httpd.conf:
Cannot load /usr/local/apache2/modules/libphp4.so into server:
/usr/local/apache2/modules/libphp4.so: Undefined symbol
"pthread_getspecific"
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/14594
--
Edit this bug report at http://bugs.php.net/?id=14594&edit=1