Bug #11451 Updated: ODBC under Apache: DLL Initialization Failed
| From: | kalowsky@php.net | Date: | Wed, 22 May 2002 02:57:33 +0000 |
| Subject: | Bug #11451 Updated: ODBC under Apache: DLL Initialization Failed | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-8145@lists.php.net to get a copy of this message | ||
ID: 11451
Updated by: kalowsky@php.net
Reported By: danielc@analysisandsolutions.com
-Status: Open
+Status: Bogus
Bug Type: ODBC related
Operating System: NT 4.0 SP6a
PHP Version: 4.0.5
New Comment:
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php
If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
Previous Comments:
------------------------------------------------------------------------
[2001-06-12 21:03:31] danielc@analysisandsolutions.com
Here's my config:
Windows NT 4.0 SP6a
Apache 1.3.20, Running as service "Logged On As" a particular user
PHP 4.0.5
Apache and PHP runs normally.
BUT, when I hit a PHP parsed page that uses ODBC connections, I get the
following error message:
Drwtsn32.exe - DLL Initialization Failed
Initialization of the dynamic link library
F:\WINNT\system32\USER32.dll failed.
The process is terminating abnormally.
This only happens when I have the Apache Service "Log On As" a separate
user via "This Account." There's no problem if I have the Apache
Service "Log On As" the "System Account."
The special user account in question has full control over all files
and directories in the F:\Program Files\Apache\* tree.
Everyone has read access on all files and directories in the F:\WINNT\*
tree.
I followed the instructions in the "User Account for Apache Service to
Run As (NT/2000)" section of
http://httpd.apache.org/docs/win_service.html
and then rebooted the
machine. Still no luck.
Nothing shows up in Apache's error.log.
This may solely be an Apache problem, but I suspect it has to do with
the interractions between PHP, ODBC and Apache. Perhaps y'all can
trace what's going on.
Probably the same problem reported in bug #8303:
http://www.php.net/bugs.php?id=8303
Thanks,
--Dan
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=11451&edit=1