#31132 [Com]: Installing PHP 5.0.3 causes 403.9 HTTP Errors under IIS 5
ID: 31132
Comment by: webwire at zonnet dot nl
Reported By: aaron at visualprose dot com
Status: No Feedback
Bug Type: IIS related
Operating System: Windows XP Professional SP 1
PHP Version: 5.0.3
New Comment:
I can confirm:
The problem is solved on the newest CVS version.
Previous Comments:
------------------------------------------------------------------------
[2005-03-15 18:03:19] mailkabin at yahoo dot com
Can't Configure the PHP version 5.0 in Win2003 System.
..
Operation System : Windows Server 2003
IIS Ver : 6.0
Other Installed Comp: ASP / ASP .net
.....
Problem :
Displays the "Page Cannot be displayed Page." or "File Not Found
Page."
------------------------------------------------------------------------
[2005-03-10 01:00:05] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
------------------------------------------------------------------------
[2005-02-28 21:14:21] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5-win32-latest.zip
------------------------------------------------------------------------
[2004-12-16 18:49:38] aaron at visualprose dot com
Description:
------------
When PHP 5.0.3 is installed under IIS 5.0 on Windows XP Professional,
all web pages (.html, .php, .asp, or .aspx) can only be viewed ten
times before IIS reports "HTTP 403.9 - Access Forbidden: Too many users
are connected". No pages (inlcluding HTML, ASP, etc.) can be viewed
once this error occurs. IIS must be restarted (which takes
approximately 5 minutes).
I have followed the steps on Microsoft's site to disable HTTP
Keep-alives, and the problem persists.
Removing the script map to PHP solves the problem, which is what leads
me to believe PHP is causing the problem
Reproduce code:
---------------
1) Install PHP 5.0.3 on Windows XP SP 1.
2) Load up a .html, .php, or .asp running on the web server.
3) Hit "Refresh" 10 times.
4) Note the 403.9 HTTP error appears. Note that IIS must be restarted
before access to any resource is allowed again.
Expected result:
----------------
No 403.9 error.
Actual result:
--------------
IIS continues to give the 403.9 error page until it is restarted.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=31132&edit=1
Thread (6 messages)