#34015 [NEW]: Test script php_gr_jp_16242.phpt mislocates libraries
| From: | RVaughn at pheedo dot com | Date: | Fri, 05 Aug 2005 20:23:32 +0000 |
| Subject: | #34015 [NEW]: Test script php_gr_jp_16242.phpt mislocates libraries | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-83055@lists.php.net to get a copy of this message | ||
From: RVaughn at pheedo dot com
Operating system: RHEL 3.0
PHP version: 4.4.0
PHP Bug Type: Unknown/Other Function
Bug description: Test script php_gr_jp_16242.phpt mislocates libraries
Description:
------------
The 'php_gr_jp_16242.phpt' test script does not look in the proper place
for PHP-required libraries, note they look in
'/usr/local/lib/php/20020429' (what the heck is that?) vs. the correct
spot: '/usr/lib/php4'. Note that this is listed in the '/etc/php.ini'
file:
; UNIX: "/path1:/path2"
include_path = ".:/php/includes:/usr/lib/php4:/usr/local/lib/php"
Errors:
PHP Warning: Unknown(): Unable to load dynamic library
'/usr/local/lib/php/20020429/imap.so' -
/usr/local/lib/php/20020429/imap.so: cannot open shared object file: No
such file or directory in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library
'/usr/local/lib/php/20020429/ldap.so' -
/usr/local/lib/php/20020429/ldap.so: cannot open shared object file: No
such file or directory in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library
'/usr/local/lib/php/20020429/mhash.so' -
/usr/local/lib/php/20020429/mhash.so: cannot open shared object file: No
such file or directory in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library
'/usr/local/lib/php/20020429/mysql.so' -
/usr/local/lib/php/20020429/mysql.so: cannot open shared object file: No
such file or directory in Unknown on line 0
This is on a Red Hat Enterprise 3.0 system with the following configure
settings:
./configure 2>configure.err '--host=i386-redhat-linux'
'--build=i386-redhat-linux' '--target=i386-redhat-linux-gnu'
'--cache-file=../config.cache' '--with-config-file-path=/etc'
'--with-config-file-scan-dir=/etc/php.d' '--enable-force-cgi-redirect'
'--disable-debug' '--enable-pic' '--disable-rpath'
'--enable-inline-optimization' '--with-bz2' '--with-db4=/usr'
'--with-curl' '--with-freetype-dir=/usr' '--with-png-dir=/usr'
'--with-gd'
'--enable-gd-native-ttf' '--without-gdbm' '--with-gettext'
'--with-ncurses'
'--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr'
'--with-openssl'
'--with-png' '--with-aspell' '--with-regex=system'
'--with-xml'
'--with-expat-dir=/usr' '--with-dom=shared,/usr'
'--with-dom-xslt=/usr'
'--with-dom-exslt=/usr' '--with-xmlrpc=shared'
'--with-pcre-regex=/usr'
'--with-zlib' '--with-layout=GNU' '--enable-bcmath'
'--enable-exif'
'--enable-ftp' '--enable-magic-quotes' '--enable-safe-mode'
'--enable-sockets' '--enable-sysvsem' '--enable-sysvshm'
'--enable-discard-path' '--enable-track-vars' '--enable-trans-sid'
'--disable-yp' '--enable-wddx' '--without-oci8'
'--with-pear=/usr/share/pear' '--with-kerberos'
'--with-mysql=shared,/usr'
'--with-snmp=shared,/usr' '--with-snmp=shared'
'--enable-ucd-snmp-hack'
'--with-unixODBC=shared' '--enable-memory-limit' '--enable-bcmath'
'--enable-shmop' '--enable-calendar' '--enable-dbx'
'--enable-dio'
'--enable-mcal' '--enable-mbstring=/usr/lib/php4/'
'--enable-mbstr-enc-trans' '--enable-mbregex'
'--with-apxs2=/usr/sbin/apxs' | tee configure.out
Reproduce code:
---------------
The test script .../ext/mbstring/tests/php_gr_jp_16242.phpt in the PHP 4.4
distro will reproduce this error on this platform.
Expected result:
----------------
The output of the code is correct except for these weird warnings:
[...warnings removed...]
string(8) "Japanese"
string(5) "UTF-8"
string(5) "UTF-8"
Actual result:
--------------
---- EXPECTED OUTPUT
string(8) "Japanese"
string(5) "UTF-8"
string(5) "UTF-8"
---- ACTUAL OUTPUT
PHP Warning: Unknown(): Unable to load dynamic library
'/usr/local/lib/php/200\
20429/imap.so' - /usr/local/lib/php/20020429/imap.so: cannot open shared
object\
file: No such file or directory in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library
'/usr/local/lib/php/200\
20429/ldap.so' - /usr/local/lib/php/20020429/ldap.so: cannot open shared
object\
file: No such file or directory in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library
'/usr/local/lib/php/200\
20429/mhash.so' - /usr/local/lib/php/20020429/mhash.so: cannot open shared
obje\
ct file: No such file or directory in Unknown on line 0
PHP Warning: Unknown(): Unable to load dynamic library
'/usr/local/lib/php/200\
20429/mysql.so' - /usr/local/lib/php/20020429/mysql.so: cannot open shared
obje\
ct file: No such file or directory in Unknown on line 0
string(8) "Japanese"
string(5) "UTF-8"
string(5) "UTF-8"
--
Edit bug report at http://bugs.php.net/?id=34015&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=34015&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=34015&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=34015&r=trysnapshot51
Fixed in CVS: http://bugs.php.net/fix.php?id=34015&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=34015&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=34015&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=34015&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=34015&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=34015&r=support
Expected behavior: http://bugs.php.net/fix.php?id=34015&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=34015&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=34015&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=34015&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=34015&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=34015&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=34015&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=34015&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=34015&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=34015&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=34015&r=mysqlcfg