#34189 [Opn->Fbk]: After Configure and Make can load symbol ap_loaded_modules
| From: | sniper@php.net | Date: | Thu, 18 Aug 2005 20:02:55 +0000 |
| Subject: | #34189 [Opn->Fbk]: After Configure and Make can load symbol ap_loaded_modules | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-83782@lists.php.net to get a copy of this message | ||
ID: 34189
Updated by: sniper@php.net
Reported By: david dot marek at mattel dot com
-Status: Open
+Status: Feedback
Bug Type: Apache related
Operating System: AIX 5.0
PHP Version: 5.1.0b3
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php5-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5-win32-latest.zip
Previous Comments:
------------------------------------------------------------------------
[2005-08-18 19:40:07] david dot marek at mattel dot com
Description:
------------
We configure and make PHP and then load it into apache. This then
brings up the error below on the server.
This works on the same build for Solaris but this is AIX.
Reproduce code:
---------------
Error occurs when either really simple or has everything in it.
Expected result:
----------------
Module loads and PHP pages viewable
Actual result:
--------------
Configuration changes cannot be saved until the following validation
errors are corrected:
Unknown - Configuration changes prevented server startup. "Cannot load
/opt/oracle/product/DCOM/AS10g/Apache/Apache/libexec/libphp5.so into
server: rtld: 0712-001 Symbol ap_loaded_modules was referenced from
module
/opt/oracle/product/DCOM/AS10g/Apache/Apache/libexec/libphp5.so(), but
a runtime definition of the symbol was not found.". Check line 195 in
file /opt/oracle/product/DCOM/AS10g/Apache/Apache/conf/httpd.conf.
Resolution: Please make sure that the value above is correct.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=34189&edit=1