#5689 [Opn->Csd]: apache fails with mysql-supported php
| From: | sniper@php.net | Date: | Fri, 02 Sep 2005 05:57:57 +0000 |
| Subject: | #5689 [Opn->Csd]: apache fails with mysql-supported php | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-84365@lists.php.net to get a copy of this message | ||
ID: 5689
Updated by: sniper@php.net
Reported By: rakeshc at hotmail dot com
-Status: Open
+Status: Closed
-Bug Type: Installation problem
+Bug Type: *General Issues
Operating System: Redhat linux 6.2
-PHP Version: Earlier? Upgrade first!
+PHP Version: 3.0.16
Previous Comments:
------------------------------------------------------------------------
[2000-07-20 07:50:07] rakeshc at hotmail dot com
I am trying to install php using the 3.0.16 source on php.net. I am
doing this since the Redhat rpm for php does not come with in-built
MySQL support. I am using the simplest switches for configure:
--with-apxs=/usr/sbin/apxs --with-mysql --with-xml \
--with-config-file-path=/etc/httpd \
--enable-track-vars
All the steps (configure, make and make install) were completed with NO
error messages. The libphp3.so file was created and I moved the php3.ini
file to /etc/httpd. I also changed the httpd.conf file like mentioned in
documentation.
BUT when I try to restart apache using /etc/rc.d/init.d/httpd, it fails
although the message for starting httpd is [OK]. When I re-install the
Redhat rpm, everything is hunky-dory again. What is happening?
I am posting this bug only after 3 sleepless nights and failure to get
help from all the documentation and newsgroups. Kindly email me if you
can help me out.
Thanks.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=5689&edit=1