#34484 [NEW]: mod_php 5/PaX/apache2 problem: apache2 refuses to load mod_php
| From: | Sjhutman at xs4all dot nl | Date: | Mon, 12 Sep 2005 20:49:42 +0000 |
| Subject: | #34484 [NEW]: mod_php 5/PaX/apache2 problem: apache2 refuses to load mod_php | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-84953@lists.php.net to get a copy of this message | ||
From: Sjhutman at xs4all dot nl
Operating system: HLFS
PHP version: 5.1.0RC1
PHP Bug Type: MySQL related
Bug description: mod_php 5/PaX/apache2 problem: apache2 refuses to load mod_php
Description:
------------
Mod_php/PaX/apache2 problem: apache2 refuses to load mod_php when ELF
relocations are prevented by PaX
Apache fails to start when loading libphp5.so. I get the following error:
cannot make segment writable for relocation: Permission denied.
I've traced the error back to the switch --with-mysql=/usr/local/mysql/.
If I compile php without that switch I don't get the error.
The culprit of the error is TEXT RELOCATION. If I use the command: readelf
-d $ /usr/lib/apache/libphp5.so | grep TEXTREL. I can see that TEXTREL is
being used. Which is causing the problems. I'm using the latest version of
mysql (5.0.12)
Switches used to compile PHP:
./configure --prefix=/usr/local/php5 --with-apxs2=/usr/sbin/apxs
--disable-cli --disable-cgi --disable-rpath --disable-short-tags
--disable-ipv6 --disable-all --with-openssl --with-zlib
--enable-mbstring=all --with-pcre-regex -enable-session --without-pear
--with-mysql=/usr/local/mysql/
--
Edit bug report at http://bugs.php.net/?id=34484&edit=1
--
Try a CVS snapshot (php4): http://bugs.php.net/fix.php?id=34484&r=trysnapshot4
Try a CVS snapshot (php5.0): http://bugs.php.net/fix.php?id=34484&r=trysnapshot50
Try a CVS snapshot (php5.1): http://bugs.php.net/fix.php?id=34484&r=trysnapshot51
Fixed in CVS: http://bugs.php.net/fix.php?id=34484&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=34484&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=34484&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=34484&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=34484&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=34484&r=support
Expected behavior: http://bugs.php.net/fix.php?id=34484&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=34484&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=34484&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=34484&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=34484&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=34484&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=34484&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=34484&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=34484&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=34484&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=34484&r=mysqlcfg