ID: 34568
User updated by: roso at despammed dot com
Reported By: roso at despammed dot com
-Status: Feedback
+Status: Open
Bug Type: Apache2 related
Operating System: Fedora 2
PHP Version: 5.1.0RC1
New Comment:
In fact, the problem doesn't come up when accessing a php script.
Please read my report. The problem is that I cannot PUT a file in a
Webdav folder after upgrading the PHP from php-5.1.0b3 to 5.1.0RC1.
And the problem is replicated on two servers with PHP 5.1.0RC1 and
mod_dav on Apache 2.0.54.
If I --enable-debug that would help catching errors when accessing a
php script, right? Maybe I need to backtrace Apache.
Previous Comments:
------------------------------------------------------------------------
[2005-09-20 22:35:39] tony2001@php.net
>To make a backtrace I will need PHP configured with --enable-debug.
Yes.
Please reopen the report when you have the backtrace. Thanks.
------------------------------------------------------------------------
[2005-09-20 22:33:00] roso at despammed dot com
Yes, php works with or withouth mod_dav.
To make a backtrace I will need PHP configured with --enable-debug.
The problem described above is absolutely similar on two servers on
which I recently upgraded PHP from php-5.1.0b3 to 5.1.0RC1.
------------------------------------------------------------------------
[2005-09-20 21:55:52] derick@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php
Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.
And if so, please make a backtrace...
------------------------------------------------------------------------
[2005-09-20 21:54:11] tony2001@php.net
Does PHP work for you with/without mod_dav enabled?
------------------------------------------------------------------------
[2005-09-20 21:35:12] roso at despammed dot com
Description:
------------
I just upgraded PHP to PHP 5.1.0RC1 and I get this nice error
whenever I try to put a file into a Webdav folder.
Windows tells me: "An error occured copying some or all of the selected
files."
At the same time Apache log shows this: ... child pid 18996 exit signal
Segmentation fault (11)
I can create new Webdav folders, move files from a folder to another
but cannot put new files.
If I disable the php module in Apache config file everything is back to
normal.
What could be a fix for this? I know that there are some conflicts
between mod_dav and the php module.
Reproduce code:
---------------
Put a file on Web server with mod_dav using Windows Explorer
Expected result:
----------------
upload file
Actual result:
--------------
error message from Windows
Segmentation Fault in Apache error log
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=34568&edit=1