#34796 [Opn->Csd]: ftp module compiled with openssl extension enabled must be loaded after ssl lib

From: Date: Sun, 09 Oct 2005 20:40:07 +0000
Subject: #34796 [Opn->Csd]: ftp module compiled with openssl extension enabled must be loaded after ssl lib
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-86291@lists.php.net to get a copy of this message
ID: 34796 Updated by: sniper@php.net Reported By: glen at delfi dot ee -Status: Open +Status: Closed -Bug Type: *Compile Issues +Bug Type: Compile Failure Operating System: PLD Linux PHP Version: 5.1.0RC1 New Comment: This bug has been fixed in CVS. Snapshots of the sources are packaged every three hours; this change will be in the next snapshot. You can grab the snapshot at http://snaps.php.net/. Thank you for the report, and for helping us make PHP better. Fix will be in PHP 5.1 and above. Previous Comments: ------------------------------------------------------------------------ [2005-10-09 22:01:49] glen at delfi dot ee Description: ------------ if you configure your php with: --with-openssl=shared --enable-ftp=shared then ftp module is compiled with openssl related functions, but not linked, this causes ftp module loaded earlier in php.ini outputing missing SSL_ symbols $ php -m PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/ftp.so' - /usr/lib/php/ftp.so: undefined symbol: SSL_shutdown in Unknown on line 0 here's patch to fix it. http://cvs.pld-linux.org/cgi-bin/cvsweb/SOURCES/php-ftp-ssllibs.patch NB: applying this patch and compiling --without-openssl is not tested. otherwise it fixes the bug described earlier. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=34796&edit=1

« previous php.bugs (#86291) next »