#35287 [Opn->Bgs]: Can't load libphp5.so - fatal error in libmtmalloc.so.1
| From: | sniper@php.net | Date: | Sat, 19 Nov 2005 11:30:52 +0000 |
| Subject: | #35287 [Opn->Bgs]: Can't load libphp5.so - fatal error in libmtmalloc.so.1 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-88532@lists.php.net to get a copy of this message | ||
ID: 35287
Updated by: sniper@php.net
Reported By: lneve at mail dot nih dot gov
-Status: Open
+Status: Bogus
Bug Type: Apache2 related
Operating System: Solaris 10
PHP Version: 5.0.5
New Comment:
There's something wrong with this library: libmtmalloc.so.1
And that's not part of PHP -> bogus.
Previous Comments:
------------------------------------------------------------------------
[2005-11-19 03:38:36] lneve at mail dot nih dot gov
Description:
------------
Here is the exact error when I start Apache:
% etc/init.d/apache start
httpd starting.
Syntax error on line 233 of /opt/httpd/conf/httpd.conf:
Cannot load /opt/httpd/modules/libphp5.so into server: ld.so.1: httpd:
fatal: libmtmalloc.so.1: DF_1_NOOPEN tagged object may not be
dlopen()'ed
Here is command I used to configure PHP:
./configure --with-mysql=/usr/local/mysql
--with-apxs2=/opt/httpd/bin/apxs --with-config-file-path=/etc
--with-mysqli=/usr
/local/mysql/bin/mysql_config --enable-mbstring --enable-libxml
--with-zlib-dir=/usr/local/lib --with-zip --with-gd --with-
jpeg-dir=/usr/local/lib --with-png-dir=/usr/local/lib
--with-xpm-dir=/usr/local/lib --with-freetype-dir=/usr/local/lib
Apache version is 2.0.55. Here is Apache configure command:
$ ./configure --disable-ipv6 --enable-so --prefix=/opt/httpd
I used gcc-3.3.2 from Sunfreeware.com to build everything.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=35287&edit=1