#35469 [Bgs]: SQLite is no more included and compiled in PHP
| From: | cbelin at free dot fr | Date: | Tue, 29 Nov 2005 10:11:14 +0000 |
| Subject: | #35469 [Bgs]: SQLite is no more included and compiled in PHP | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-89371@lists.php.net to get a copy of this message | ||
ID: 35469
User updated by: cbelin at free dot fr
Reported By: cbelin at free dot fr
Status: Bogus
Bug Type: SQLite related
Operating System: Windows XP sp2
PHP Version: 5.1.1
New Comment:
It works !
So, to enabled SQLite under PHP 5.1.1/Win32, you must put in your
php.ini file the following lines :
extension=php_pdo.dll
extension=php_pdo_sqlite.dll
extension=php_sqlite.dll
Previous Comments:
------------------------------------------------------------------------
[2005-11-29 11:04:42] sniper@php.net
You need to also include php_pdo.dll in php.ini.
(php_sqlite.dll requires it to be loaded before it)
------------------------------------------------------------------------
[2005-11-29 11:02:45] cbelin at free dot fr
Description:
------------
Before upgrading to PHP version 5.1.1, SQLite was included in PHP
distribution and enabled by default (and worked fine !).
Since version 5.1.1, SQLite doesn't seem to be included anymore.
Enabling SQLite extension (php_sqlite.dll) in php.ini doesn't solve
anything : it produces instead a PHP startup error.
Reproduce code:
---------------
<?php
echo sqlite_libversion();
?>
Expected result:
----------------
2.8.14
Actual result:
--------------
Without enabling SQLite extension (php_sqlite.dll) :
"Fatal error: Call to undefined function sqlite_libversion() in ... on
line ..."
With SQLite extension enabled :
"PHP Warning: PHP Startup: Unable to load dynamic library
'...\PHP\ext\php_sqlite.dll' - Le module spécifié est introuvable. in
Unknown on line 0"
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=35469&edit=1