#35432 [Opn->Asn]: make fails with PDO and MySQL5
| From: | sniper@php.net | Date: | Wed, 30 Nov 2005 16:31:26 +0000 |
| Subject: | #35432 [Opn->Asn]: make fails with PDO and MySQL5 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-89500@lists.php.net to get a copy of this message | ||
ID: 35432
Updated by: sniper@php.net
Reported By: mail at philipp-wagner dot com
-Status: Open
+Status: Assigned
Bug Type: PDO related
Operating System: SuSE Linux 8.0
PHP Version: 5CVS-2005-11-27 (snap)
Assigned To: wez
New Comment:
Wez, so, enabling by default is good thing?
Hint: You should always use --disable-all :)
Previous Comments:
------------------------------------------------------------------------
[2005-11-30 16:25:12] mail at philipp-wagner dot com
Well, I thought this might be the problem (mixing of shared and static
libraries)... But now the check seems to be too strict.
I first tried to build with --enable-pdo=shared
--with-pdo-mysql=shared,/usr/local/mysql
Now I got the following error message:
You've configured extension sqlite to build statically, but it depends
on extension pdo, which you've configured to build shared.
You either need to build sqlite shared or build pdo statically for the
build to be successful.
sqlite is enabled by default (I didn't specify exlicitly specify pdo
sqlite support as a configure option).
./configure --help doesn't say anything about an option like
--with-pdo-sqlite, but I tried to use it anyways (or what else should I
do to specify shared pdo sqlite support?). So I ran ./configure with
--with-pdo-sqlite=shared
This worked out quite well at first, configure gave me an output like
checking for sqlite 3 driver for PDO... yes, shared
But then, a bit further down, I got the error message again:
checking for PDO includes... (cached)
/usr/local/src/php5.1-200511301330/ext
checking for lemon... no
configure: warning: lemon versions supported for regeneration of
libsqlite parsers: 1.0 (found: none).
configure: error:
You've configured extension sqlite to build statically, but it depends
on extension pdo, which you've configured to build shared.
You either need to build sqlite shared or build pdo statically for the
build to be successful.
I actually think, if you specify --enable-pdo=shared, all pdo
"submodules" should also be built shared, as it reduces confusion and
is the only way to get a working build anyways (it seems it is not
possible to mix shared and static pdo libraries, so there's no need to
specify it seperately).
Also, the documentation doesn't say anything about how to build the
specific PDO modules. It just suggests building PDO with
--enable-pdo=shared, but doesn't say which configure options to use for
MySQL PDO support etc. (I just got it from the ./configure --help
output), and also doesn't mention the shared "problem".
------------------------------------------------------------------------
[2005-11-30 05:48:21] wez@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5.1-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5.1-win32-latest.zip
Please try the next PHP 5.1 snapshot.
It features an improved error message that should catch conflicting
configure options.
------------------------------------------------------------------------
[2005-11-28 17:53:13] mail at philipp-wagner dot com
Yes, I see that now too, but it's not a problem for MySQL, as
/usr/local/mysql is the prefix (it's a MySQL binary .tar.gz
distribution).
------------------------------------------------------------------------
[2005-11-27 23:43:30] sniper@php.net
One note about your usage of the configure options: There aren't any
options that expect the path to the libraries.
Every single one of them expects the install prefix.
In most cases it's either /usr or /usr/local and not /usr/lib or
/usr/local/lib..
------------------------------------------------------------------------
[2005-11-27 22:40:17] tony2001@php.net
Wez, one more for you.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/35432
--
Edit this bug report at http://bugs.php.net/?id=35432&edit=1