ID: 35506
Updated by: sniper@php.net
Reported By: broadmind at magicn dot com
-Status: Open
+Status: Feedback
Bug Type: MySQL related
Operating System: windows 2000 server
PHP Version: 5CVS-2005-12-01 (snap)
New Comment:
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php
If you can provide more information, feel free to add it
to this bug and change the status back to "Open".
Thank you for your interest in PHP.
Previous Comments:
------------------------------------------------------------------------
[2005-12-01 17:35:56] broadmind at magicn dot com
Description:
------------
My server environment is,
CPU : AMD Opteron 240 x2 (2 cpu)
RAM : 2 GB
Apache 1.3.34
Mysql 5.0.16
PHP : 5.1.2-dev Snap stable version.
In error logs, I could find the following error message frequently.
FATAL: erealloc(): Unable to allocate 24576 bytes
So, opening windows task manager, I have monitored the memory usage of
Apache server.
I found this log is happen when it is over 240MB duing to heavily
access to mysql through a PHP page.
Because the memory size of my server is 2GB, it is nonsense to say that
this problem is duing to the lack of memory.
In my guess, there may be a memory leak in the memory manager.
Actual result:
--------------
FATAL: erealloc(): Unable to allocate 24576 bytes
the above log is leaved in error.log file and Apache server is
restarted, causing the lose of POST data or "page not found".
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=35506&edit=1