#35605 [NEW]: configure fails with aolserver4
| From: | sam at caveman dot org | Date: | Thu, 08 Dec 2005 19:04:57 +0000 |
| Subject: | #35605 [NEW]: configure fails with aolserver4 | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-89975@lists.php.net to get a copy of this message | ||
From: sam at caveman dot org
Operating system: Debian 3.1
PHP version: 5.1.1
PHP Bug Type: *Compile Issues
Bug description: configure fails with aolserver4
Description:
------------
PHP 5.1.1 configure fails with aolserver, always asking that
--with-aolserver-src be provided even though it is provided.
Reproduce code:
---------------
./configure --with-aolserver --with-aolserver=/path/to/aolserver/src
Expected result:
----------------
I expect configure to produce a makefile that will compile the aolserver
module.
Actual result:
--------------
sam@caveman:~/downloads/php.net/php-5.1.1$ ./configure --with-aolserver
--with-aolserver-src=/home/sam/downloads/aolserver.org/aolserver-4.0.10
loading cache ./config.cache
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking whether gcc and cc understand -c and -o together... yes
checking how to run the C preprocessor... gcc -E
checking for AIX... no
checking whether ln -s works... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for re2c... re2c
checking for re2c version... invalid
configure: warning: You will need re2c 0.98 or later if you want to
regenerate PHP parsers.
checking for gawk... gawk
checking for bison... bison -y
checking for bison version... 1.875 (ok)
checking for flex... flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for working const... yes
checking for flex version... invalid
configure: warning: flex versions supported for regeneration of the
Zend/PHP parsers: 2.5.4 (found: 2.5.31).
checking whether to force non-PIC code in shared modules... yes
checking for pthreads_cflags... -pthread
checking for pthreads_lib...
Configuring SAPI modules
checking for AOLserver support... yes
configure: error: Please specify the path to the source distribution of
AOLserver using --with-aolserver-src=DIR
--
Edit bug report at http://bugs.php.net/?id=35605&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=35605&r=trysnapshot44
Try a CVS snapshot (PHP 5.1): http://bugs.php.net/fix.php?id=35605&r=trysnapshot51
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=35605&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=35605&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=35605&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=35605&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=35605&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=35605&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=35605&r=support
Expected behavior: http://bugs.php.net/fix.php?id=35605&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=35605&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=35605&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=35605&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=35605&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=35605&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=35605&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=35605&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=35605&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=35605&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=35605&r=mysqlcfg