Bug #14510 Updated: Unknown error in mail function
| From: | mfischer@php.net | Date: | Sun, 02 Jun 2002 17:48:22 +0000 |
| Subject: | Bug #14510 Updated: Unknown error in mail function | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-9182@lists.php.net to get a copy of this message | ||
ID: 14510
Updated by: mfischer@php.net
Reported By: davidfelton@codemasters.com
-Status: Open
+Status: Feedback
Bug Type: Mail related
Operating System: Windows 2000 Terminal, IIS5
PHP Version: 4.1.0
New Comment:
SMTP error reporting has been improved, please try a snapshot from
http://snaps.php.net/win32/php4-win32-latest.zip
Previous Comments:
------------------------------------------------------------------------
[2002-04-15 15:28:03] jjgracia@lazerpro.com
I got the same error on Win2000+IIS5. I used this on the php page to
overwrite ini values:
<?php
ini_set("sendmail_from",NULL);
ini_set("sendmail_path",NULL);
ini_set("SMTP","aaaa.xxxx.cccc.gggg");// Add SMTP server IP
mail($mail_to, $mail_subject, $mail_body, $mail_headers);
?>
It seems you have to explicitly tell PHP that Sendmail is not in the
server :)
------------------------------------------------------------------------
[2002-03-05 09:53:59] davidfelton@codemasters.com
If your php can't read the ini file (patch of file in phpinfo shows up
as c:/winnt/ instead of c:/winnt/php.ini) You need to make sure that
php has access to read the php.ini file through your security
settings.
My solution to the problem was to replace all the calls to mail() with
my own function that writes out the raw emails to the mail pickup
folder in c:\inetpub\mailroot\
- it took ages!
------------------------------------------------------------------------
[2002-03-05 09:13:08] ibasevitch@homtail.com
i have the same problme with win nt 4.0 terminal edition.
did you find a solution...?
it seems like it can't find the ini file.
thanks
------------------------------------------------------------------------
[2001-12-18 04:23:01] davidfelton@codemasters.com
So, any other ideas?
------------------------------------------------------------------------
[2001-12-17 04:20:17] davidfelton@codemasters.com
smtp server is set to be localhost, which works fine with php 4.0.6
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/14510
--
Edit this bug report at http://bugs.php.net/?id=14510&edit=1