#34750 [Opn]: filesize()/stat() fails on too big files
| From: | aulbach at mayflower dot de | Date: | Mon, 30 Jan 2006 08:35:01 +0000 |
| Subject: | #34750 [Opn]: filesize()/stat() fails on too big files | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-92615@lists.php.net to get a copy of this message | ||
ID: 34750
User updated by: aulbach at mayflower dot de
Reported By: aulbach at mayflower dot de
Status: Open
Bug Type: Feature/Change Request
Operating System: all
PHP Version: 4.4.0
New Comment:
Or think of the case, that you want to read data from a database, which
is >32 bit. Or 32 bit unsigned. That's a real life problem!
We have those problems more and more.
...
Today I got this message from a "kid":
"stat() in perl work propertly !!!
perl - rulezzz !"
:)
Previous Comments:
------------------------------------------------------------------------
[2005-10-06 10:38:36] aulbach at mayflower dot de
- it's not a feature request, it's a workarround over a problem, that
otherwise cannot be solved within PHP! (without calling external
programs)
- For longer term, there is no question, that PHP needs 64 bit integer.
------------------------------------------------------------------------
[2005-10-06 10:22:20] derick@php.net
This is not a bug, but a feature request.
------------------------------------------------------------------------
[2005-10-06 10:08:18] aulbach at mayflower dot de
Description:
------------
Writing a php command-line script, which scans all my files on my big
raid, I mentioned, that PHP is not able to handle the case, when the
files are bigger than 4 GB. But this is more and more used, cause for
example complete DVD-images are just put in one file.
PHP itself cannot handle bigger numbers, cause it uses 32 bit integer.
Currently I help me with
ls but that's no real solution.
Everyone is using 64 bit integer now. There are many cases, timestamps
for example.
For now I suggest, that the number is stored as a string, if it gets
too big. I use that number only to write it into the database (which
can handle 64 bit int), so for that case this is correct.
For long term, I suggest a mechanism, that automatically assigns 64 bit
integer, if the number gets too big.
Reproduce code:
---------------
$fsize = filesize($path); // returns invalid if file is too big, the
rest of the program will fail, if I assume, that there will be a
number
OR
$stats = stat($path); // complete record invalid
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=34750&edit=1