#36504 [Opn->Fbk]: mysql as self contained extension compile failed

From: Date: Mon, 27 Feb 2006 07:43:43 +0000
Subject: #36504 [Opn->Fbk]: mysql as self contained extension compile failed
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-93696@lists.php.net to get a copy of this message
ID: 36504 Updated by: tony2001@php.net Reported By: boonkit at gmail dot com -Status: Open +Status: Feedback Bug Type: Compile Failure Operating System: fedora core 3 PHP Version: 4.4.2 New Comment: I can't reproduce it. "also failed" isn't very good description of the problem, please add more details. Previous Comments: ------------------------------------------------------------------------ [2006-02-27 03:52:13] boonkit at gmail dot com Before installed the build installed, mysql self contained extension compilation already failed. By the way, already tested in other machine, which only has the zlib rpm installation, also failed. And i tried another configuraion "--with-php-config=/usr/local/php4.4.2/bin/php-config", it worked if compiled with bundled mysql library (v 3.23.49). Seem like this is not caused by zlib. Please help, thank you. ------------------------------------------------------------------------ [2006-02-24 13:58:25] tony2001@php.net If you have both zlib RPMs and manual build installed, then it's most likely some mess with headers/libraries. Not PHP problem. ------------------------------------------------------------------------ [2006-02-24 13:38:52] boonkit at gmail dot com i have tried "--with-zlib-dir=/usr" and "--with-zlib-dir", both didn't work. And i'm sure zlib and zlib-devel was installed using yum. The, i installed zlib from source at "/usr/local/zlib", this is why i set the path. Thank you. ------------------------------------------------------------------------ [2006-02-24 13:16:56] tony2001@php.net Why do you need to use --with-zlib-dir=/usr/local/zlib? I bet every Linux has zlib in standard path and you don't need to pass it explicitly. ------------------------------------------------------------------------ [2006-02-24 08:55:31] tony2001@php.net Put your config.log somewhere and provide the link. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/36504 -- Edit this bug report at http://bugs.php.net/?id=36504&edit=1

« previous php.bugs (#93696) next »