#36250 [Opn]: PHP Causes ORA-07445 Core dump in Oracle server 9.2.x
| From: | fred dot cohen at iridium dot com | Date: | Sat, 04 Mar 2006 06:33:54 +0000 |
| Subject: | #36250 [Opn]: PHP Causes ORA-07445 Core dump in Oracle server 9.2.x | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-93903@lists.php.net to get a copy of this message | ||
ID: 36250
User updated by: fred dot cohen at iridium dot com
Reported By: fred dot cohen at iridium dot com
Status: Open
Bug Type: OCI8 related
Operating System: Solaris 9
PHP Version: 5.1.2
New Comment:
Oracle is claiming OCIPing isn't a supported in anything less than
oracle 10.2
Previous Comments:
------------------------------------------------------------------------
[2006-02-01 19:49:51] fred dot cohen at iridium dot com
Description:
------------
This isn't a bug in PHP, but I'm submitting it since Oracle currently
has no patch available and it's cause isn't obvious.
Using the Instant Client 10.2 and PHP 5.1.2 connecting to Oracle
9.2.0.7 we began seeing ORA-07445 errors immediately after upgrading to
the versions listed. They may appear to occur intermittently, but they
can happen as frequently as the oci8.ping_interval value.
I've traced it down to the OCIPing call in the oci extension.
It turns out any calls to OCIPing cause the error in the server.
Workaround:
In php.ini [oci8] section, set:
oci8.ping_interval=-1
I'll provide updates about possible patches from Oracle as soon as
they're able to respond.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=36250&edit=1