#36713 [NEW]: apache and opteron 64bit cannot load module
| From: | abarbieri at isis dot sm | Date: | Mon, 13 Mar 2006 10:09:32 +0000 |
| Subject: | #36713 [NEW]: apache and opteron 64bit cannot load module | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-94261@lists.php.net to get a copy of this message | ||
From: abarbieri at isis dot sm
Operating system: solaris 10
PHP version: 5.1.2
PHP Bug Type: *Configuration Issues
Bug description: apache and opteron 64bit cannot load module
Description:
------------
When you compile PHP on a Opteron AMD 64 arch. with the command:
CC='gcc -m64' ./configure --with-apxs2=/usr/local/apache2/bin/apxs
--with-mysql=/usr/local/mysql/mysql-max-5.0.15-solaris10-x86_64
--with-zlib=/usr
note:mysql 64bit,libxml 64bit,openssl 64bit,libiconv 64bit
This kind of module compiled and installed with no errors cannot be loaded
dinamically on a apache 2 server.
When i exclude the Loadmodule directive all runs OK.
p.s.
httpd -V
Server version: Apache/2.0.55
Server built: Mar 13 2006 10:54:38
Server's Module Magic Number: 20020903:11
Architecture: 64-bit
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_FCNTL_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT="/usr/local/apache2"
-D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
-D DEFAULT_PIDLOG="logs/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="logs/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"
ldd ldd /usr/local/apache2/modules/libphp5.s
libz.so.1 => /usr/lib/64/libz.so.1
libresolv.so.2 => /lib/64/libresolv.so.2
libm.so.2 => /lib/64/libm.so.2
libnsl.so.1 => /lib/64/libnsl.so.1
libsocket.so.1 => /lib/64/libsocket.so.1
libxml2.so.2 => /lib/64/libxml2.so.2
libiconv.so.2 => /usr/local/lib/libiconv.so.2
libc.so.1 => /lib/64/libc.so.1
libmp.so.2 => /lib/64/libmp.so.2
libmd5.so.1 => /lib/64/libmd5.so.1
libscf.so.1 => /lib/64/libscf.so.1
libpthread.so.1 => /lib/64/libpthread.so.1
libgcc_s.so.1 => /usr/sfw/lib/amd64//libgcc_s.so.1
libdoor.so.1 => /lib/64/libdoor.so.1
libuutil.so.1 => /lib/64/libuutil.so.1
Reproduce code:
---------------
Versions:
http 2.0.55
mysql 5.0.15 max (binary for solaris 10 release pack)
php 5.0.5
libxml2 2.6.11
libiconv 1.9.1
openssl 0.9.8a
glib 2.8.0
zlib 1.2.3
When you compile PHP on a Opteron AMD 64 arch. with the command:
CC='gcc -m64' ./configure --with-apxs2=/usr/local/apache2/bin/apxs
--with-mysql=/usr/local/mysql/mysql-max-5.0.15-solaris10-x86_64
--with-zlib=/usr
note:mysql 64bit,libxml 64bit,openssl 64bit,libiconv 64bit
with
CC='gcc -m64' ./configure --enable-so --enable-ssl
--with-ssl=/usr/local/ssl
Expected result:
----------------
apachectl configtest or start with no error
Loadmodule modules/libphp5.so with noerror for the basic configuration
--
Edit bug report at http://bugs.php.net/?id=36713&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=36713&r=trysnapshot44
Try a CVS snapshot (PHP 5.1): http://bugs.php.net/fix.php?id=36713&r=trysnapshot51
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=36713&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=36713&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=36713&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=36713&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=36713&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=36713&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=36713&r=support
Expected behavior: http://bugs.php.net/fix.php?id=36713&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=36713&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=36713&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=36713&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=36713&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=36713&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=36713&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=36713&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=36713&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=36713&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=36713&r=mysqlcfg