Bug #9852 Updated: Header redirect and db connection cause "CGI misbehaved"
| From: | michael dot lidgren at journalistgruppen dot se | Date: | Tue, 04 Jun 2002 14:45:48 +0000 |
| Subject: | Bug #9852 Updated: Header redirect and db connection cause "CGI misbehaved" | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-9473@lists.php.net to get a copy of this message | ||
ID: 9852
Updated by: michael.lidgren@journalistgruppen.se
Reported By: ron.baldwin@sourceprose.com
Status: Open
Bug Type: IIS related
Operating System: Windows 2000
PHP Version: 4.1.1
New Comment:
This is from the mailing list; i think it might be relevant to this
bug:
<snip>
Hi,
we've a lot of trouble using PHP on IIS5/Win2000sp2-Server.
The machine is a 2xPIII(1,3Ghz), 1280MB RAM, really fast.
The problem is that sometimes the IIS doesn't execute the php.exe,
instead it shows a "CGI Application error - wrong or incomplete header
data...." This problem only occurs on this fast server and only with a
website that uses frames.
I suppose that the IIS launches different threads to render the frames
and isn't able to do the IO to the php.exe for every thread.
To test this we wrote a little script wich shows 12 Frames, filled with
a little PHP-Skript that only shows one line of text.
On the slow machine theres no problem. On the fast machine, same
software, we get the cgi-error in round about every 50th or 60th frame
(refresh..)
Regards,
Jan Schmitz
</snip>
--Michael
Previous Comments:
------------------------------------------------------------------------
[2002-06-04 10:35:22] michael.lidgren@journalistgruppen.se
My uneducated guess would be that two database connections in rapid
succession produces the error. Just for fun, I tried:
$aconn = mssql_pconnect($db_servername, $login, $passwd);
$bconn = mssql_pconnect($db_servername, $login, $passwd);
... and got this interesting error:
<B>Warning: Unknown persistent list entry type in module shutdown (22)
in Unknown on line 0</B>
--Michael
------------------------------------------------------------------------
[2002-06-02 23:48:42] timoid@getonit.net.au
I can make this error happen every time within virtual hosts...
the default www page however, works perfectly.
weird
------------------------------------------------------------------------
[2002-06-02 20:16:00] scott@datalink.net.au
Another observation - when my script runs correctly, it takes a second
to execute. When the CGI error occurs, it returns very quickly.
This indicates that it fails on or around the first db statement (I'm
guessing around the mssql_connect() statement).
It's also consistent with the other users' comments on redirecting
seeming to fail with a CGI error, but the location bar of the browser
changing. The redirect *is* working, but it's the second page that
fails (probably around reconnecting to the database).
------------------------------------------------------------------------
[2002-06-02 17:09:50] theo.schoeberl@tssystems.de
We have the same problem (see Bug #11788).
Loading the page outside the local network (over the internet) works in
99%.
Within the local network the problem occurs on nearly ever 2nd load.
After a relaod request of the individual frame (context menu - right
mouse buttom) it works fine!
It seems that the problem depends from the line speed and not the
machines speed.
------------------------------------------------------------------------
[2002-05-28 09:16:11] scott@datalink.net.au
Some further info on the problem:
I applied the slowdown script after each query (in the simpleQuery
method of PEAR's mssql driver) but I still got the occasional CGI Error
(and it was awfully slow, too).
I then applied the slowdown script at the start of each script, but
still to no avail.
What I did notice was that it did help the problem, but not eliminate
it. My problem was still there when I refreshed my entire frameset
(which caused 6 scripts to run mssql db commands simultaneously).
Often 2 or 3 of these scripts failed with CGI errors.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/9852
--
Edit this bug report at http://bugs.php.net/?id=9852&edit=1