#37058 [Opn->Fbk]: Building with Informix does not work
| From: | sniper@php.net | Date: | Wed, 12 Apr 2006 17:01:03 +0000 |
| Subject: | #37058 [Opn->Fbk]: Building with Informix does not work | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-95701@lists.php.net to get a copy of this message | ||
ID: 37058
Updated by: sniper@php.net
Reported By: gquiring at gmail dot com
-Status: Open
+Status: Feedback
-Bug Type: *Compile Issues
+Bug Type: Compile Failure
Operating System: Solaris 9
PHP Version: 5.1.2
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php5.1-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5.1-win32-latest.zip
Previous Comments:
------------------------------------------------------------------------
[2006-04-12 15:21:42] gquiring at gmail dot com
Messages during compile:
*** Warning: Linking the shared library libphp5.la against the
non-libtool
*** objects /u/home/garyq/informix/lib/esql/ is not portable!
------------------------------------------------------------------------
[2006-04-12 15:19:47] gquiring at gmail dot com
Description:
------------
Apache 1.3.34 PHP 5.1.4 Informix CSDK 2.9UC4 Solaris 9
When executing apache:
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp5.so into server: ld.so.1:
./httpd:
fatal: relocation error: file
/u/home/garyq/informix/lib/esql/libifsql.so: symbo
l ifx_checkAPI: referenced symbol not found
Env:
INFORMIXSQLHOSTS=/u/home/garyq/informix/etc/sqlhosts
INFORMIXSERVER=dev1
INFORMIXDIR=/u/home/garyq/informix
LD_LIBRARY_PATH=/u/home/garyq/informix/lib:/u/home/garyq/informix/lib/esql:/u/home/garyq/informix/lib/tools:/usr/local/lib:/usr/lib:/var/local/lib:/opt/SUNWspro
/lib:/usr/openwin/lib
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=37058&edit=1