#37173 [Asn->Bgs]: dba_open gives an error about uncompatible modifiers when they aren't.
| From: | helly@php.net | Date: | Mon, 24 Apr 2006 01:25:04 +0000 |
| Subject: | #37173 [Asn->Bgs]: dba_open gives an error about uncompatible modifiers when they aren't. | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-96139@lists.php.net to get a copy of this message | ||
ID: 37173
Updated by: helly@php.net
Reported By: myckel at sdf dot lonestar dot org
-Status: Assigned
+Status: Bogus
Bug Type: DBM/DBA related
-Operating System: Gentoo Linux
+Operating System: *
PHP Version: 5.1.2
Assigned To: helly
New Comment:
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to
report
a bug at http://bugs.php.net/how-to-report.php
The real error is that php has to use th elock provided by the lib.
This is being solved with 5.1.3. Now unfortunatley this does not allow
to test whether the db file is being locked.
Previous Comments:
------------------------------------------------------------------------
[2006-04-23 19:27:08] tony2001@php.net
Marcus, you broke it by this commit:
http://cvs.php.net/viewcvs.cgi/php-src/ext/dba/dba.c?r1=1.111&r2=1.112
------------------------------------------------------------------------
[2006-04-23 18:23:03] myckel at sdf dot lonestar dot org
Tried to build the latest snapshot and installed. phpinfo() gave: PHP
Version 5.1.3RC4-dev (as confirmation that the latest php is in use).
But the bug keeps appearing when I tried the script again. Seems that
the bug isn't fixed yet.
------------------------------------------------------------------------
[2006-04-23 15:29:13] tony2001@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php5.1-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php5.1-win32-latest.zip
------------------------------------------------------------------------
[2006-04-23 15:21:58] myckel at sdf dot lonestar dot org
Description:
------------
Since my last distro php upgrade I can't open a DBA file with the "rdt"
modifier (on a non-opened file). It gives an error on a n incompatible
modifier combo. The PHP version is: PHP Version 5.1.2-pl1-gentoo
Reproduce code:
---------------
<?php
/* config.db4 exists, but isn't opened */
dba_open("config.db4",rdt,db4);
?>
Expected result:
----------------
Empty page, no errors.
Actual result:
--------------
HTTP server returns the following error:
Warning: dba_open(config.db4,rdt) [function.dba-open]: You cannot
combine modifiers - (no lock) and t (test lock) in
/var/www/localhost/htdocs/test.php on line 4
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=37173&edit=1