#37177 [Bgs->Opn]: with-libxml option in ./configure ignored

From: Date: Mon, 24 Apr 2006 09:33:20 +0000
Subject: #37177 [Bgs->Opn]: with-libxml option in ./configure ignored
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-96150@lists.php.net to get a copy of this message
ID: 37177 User updated by: mhalligan at bitpusher dot com Reported By: mhalligan at bitpusher dot com -Status: Bogus +Status: Open Bug Type: Compile Failure Operating System: SuSE Linux Enterprise 9 SP3 PHP Version: 5.1.2 New Comment: That was a typo in my posting. However, the real problem lies in the fact that ./configure looks for libxml2-config first in $PATH, then in the variable set with --with-libxml-dir .. This is incorrect behavior. Previous Comments: ------------------------------------------------------------------------ [2006-04-24 09:18:07] tony2001@php.net It won't be ignored if you actually pass it to the configure. Currently because of missing "\" you are executing two commands: 1) ./configure 2) --with-openssl etc... No bug here. ------------------------------------------------------------------------ [2006-04-24 04:27:56] mhalligan at bitpusher dot com Description: ------------ ./configure --with-libxml-dir appears to not actually be utilized, and custom installations of libxml2 fail. Reproduce code: --------------- ./configure --with-openssl \ --with-apxs=/bitpusher/services/apache/sbin/apxs \ --with-pear=/bitpusher/services/apache \ --enable-mbstring \ --with-pdo-mysql=/bitpusher/services/mysql \ --with-zlib \ --with-gd \ --with-curl \ --with-libxml-dir=/bitpusher Expected result: ---------------- ./configure should find my custom installation of libxml. Actual result: -------------- Configuring extensions checking whether to enable LIBXML support... yes checking libxml2 install dir... no checking for xml2-config path... /usr/bin/xml2-config configure: error: libxml2 version 2.6.11 or greater required. ../php-build.sh: line 3: --with-openssl: command not found -------- I've installed libxml2 with --prefix=/bitpusher and that installation is successful. However, the ./configure script appears to still try to use default xml2 configuration scripts, like /usr/bin/xml2-config. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=37177&edit=1

« previous php.bugs (#96150) next »