#37287 [Opn->Bgs]: oci8 extension won't load with Oracle 9i

From: Date: Wed, 03 May 2006 02:42:10 +0000
Subject: #37287 [Opn->Bgs]: oci8 extension won't load with Oracle 9i
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-96508@lists.php.net to get a copy of this message
ID: 37287 User updated by: crescentfreshpot at yahoo dot com Reported By: crescentfreshpot at yahoo dot com -Status: Open +Status: Bogus Bug Type: OCI8 related Operating System: WinXP PHP Version: 5.1.3 New Comment: After downloading the latest 10g instant client dlls all is fine. Sorry. Previous Comments: ------------------------------------------------------------------------ [2006-05-03 01:54:03] crescentfreshpot at yahoo dot com Description: ------------ oci8 extension won't load with latest win32 binaries. Oracle version is 9.2.0.1.0 php.ini: extension_dir = "./ext" extension=php_oci8.dll Happens with 5.1.3RC3 too. All loads fine with 5.1.3RC2. Reproduce code: --------------- at the cmd prompt: php -v Expected result: ---------------- PHP 5.1.3 (cli) (built: May 1 2006 00:31:46) Copyright (c) 1997-2006 The PHP Group Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies Actual result: -------------- Error message box (php.exe): "The procedure entry point OCILobRead2 could not be located in the dynamic link library OCI.dll". PHP Warning: PHP Startup: Unable to load dynamic library './ext\php_oci8.dll' - The specified procedure could not be found. in Unknown on line 0 PHP 5.1.3 (cli) (built: May 1 2006 00:31:46) Copyright (c) 1997-2006 The PHP Group Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=37287&edit=1

« previous php.bugs (#96508) next »