Bug #16186 Updated: include path in the module version, using sub dir as php causing error
| From: | sniper@php.net | Date: | Fri, 07 Jun 2002 00:09:24 +0000 |
| Subject: | Bug #16186 Updated: include path in the module version, using sub dir as php causing error | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-9679@lists.php.net to get a copy of this message | ||
ID: 16186
Updated by: sniper@php.net
Reported By: HummerX123@hotmail.com
-Status: Open
+Status: Bogus
Bug Type: *General Issues
Operating System: Win2k
PHP Version: 4.1.2
New Comment:
Sorry, but the bug system is not the appropriate forum for asking
support questions. Your problem does not imply a bug in PHP itself.
For a list of more appropriate places to ask for help using PHP,
please visit http://www.php.net/support.php
Thank you for your interest in PHP.
Previous Comments:
------------------------------------------------------------------------
[2002-05-04 04:23:38] slach@ems.ru
for win32 php4.2.0+Apache1.3.x platform
replace in httd.conf DocumentRoot path like /usr/... on c:/usr/...
(with drive literal)
but in this configuration not work correct mod_rewrite
------------------------------------------------------------------------
[2002-04-16 03:54:57] yeuxquipic@free.fr
I've the same problem
i've test php 4.1.2, 4.2.0rc3 , 4.2.0rc4.[Tue Apr 16
My msg is:
09:45:42 2002] [error] PHP Warning: Failed opening '/serveur
web/apache/htdocs/info.php' for inclusion (include_path='.;c:\serveur
web\php-4.2.0RC4-win32\pear') in Unknown on line 0
------------------------------------------------------------------------
[2002-04-09 05:04:13] mak77@anvi.it
This problem doesn't exists on Windows XP as i can see....
------------------------------------------------------------------------
[2002-04-09 05:02:02] mak77@anvi.it
I have a similar problem but only with pages that contain phpinfo()
If i activate the include_path in the php.ini ALL scripts give the same
error ("Warning: failed opening...."), if i comment out the
include_path instead only phpinfo() gives this error but the other
functions work fine
System is:
Win 2000 Server sp2, Security Rollup Patch 1, all the patches founded
by HFNETCHK.exe were installed.
PHP 4.1.2 as ISAPI with php.ini-recommended
IIS 5.0 with all patches.
------------------------------------------------------------------------
[2002-03-20 10:38:41] HummerX123@hotmail.com
after I upgrade to 4.1.2 from 4.1.1 the php module version of Apache
stop working
all my working php script would throw an error
Warning: Failed opening 'path_of_the_script' for inclusion
(include_path='c:\php4\pear') in Unknown on line 0
even the one that doesn't require the use of include or require
function. In fact one of the script only have phpinfo() in it.
I've try to play around with the include_path however this make no
different.
I add my comment to a bogus post and also a Analyzed post so I thought
I would post it again
Anyway I move to the cgi version and get it to work fine, however I
found another bug, when I use a sub directly with the name php
immediate after the webroot any php page in that directly then Apache
will throw a not found error
Not Found
The requested URL /php/test.php was not found on this server.
I check in the log and this is what I found
[Wed Mar 20 10:37:18 2002] [error] [client 192.168.1.101] (2)No such
file or directory: script not found or unable to stat: c:/php/test.php
It seem to me that because I name the directory php, somehow it confuse
php and it start to pick up the page from c:\php which is where I
install php and not from the webroot.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=16186&edit=1