#37427 [Fbk->Opn]: relocation R_X86_64_32... recompile with -fPIC...
| From: | vktechnology at uk2 dot net | Date: | Mon, 15 May 2006 17:00:47 +0000 |
| Subject: | #37427 [Fbk->Opn]: relocation R_X86_64_32... recompile with -fPIC... | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-97122@lists.php.net to get a copy of this message | ||
ID: 37427
User updated by: vktechnology at uk2 dot net
Reported By: vktechnology at uk2 dot net
-Status: Feedback
+Status: Open
Bug Type: Compile Failure
Operating System: fedora
PHP Version: 5.1.4
New Comment:
Hello tony2001
Yes I use this lib64 option
./configure --libdir=/usr/lib64 ...
everything can past make and make install..
but after this cannot use mySQL..
i donlt know what to do now..
here my phpinfo
http://202.142.221.59/info.php
*********
this one i test to connect with mysql
http://202.142.221.59/config.php
I have this error
"Fatal error: Call to undefined function mysql_connect() "
****
I just have got new server for 2-3 days
Spec
Intel Dual Xeon 3.2GHz, Cach 2MB
Ram 4GB
If you would like to login SSH to my server to check and testing...I
can give you root access...
Previous Comments:
------------------------------------------------------------------------
[2006-05-15 14:18:59] tony2001@php.net
Did you try to use --with-libdir=lib64 option?
------------------------------------------------------------------------
[2006-05-15 14:05:10] vktechnology at uk2 dot net
Sory missed type
if configure like this cannot fix problem
"--with-mysql-dir=/usr/local/mysql"
it can complie and make insall
but after install
and when use witj PHP it doesn't work
will see this error in php
"Fatal error: Call to undefined function mysql_connect() "
------------------------------------------------------------------------
[2006-05-15 14:02:01] vktechnology at uk2 dot net
another problem..after configure with
The problem is fixed when using
--with-mysql-dir=/usr/local/mysql
instead of
--with-mysql=/usr/local/mysql
********************************
cannot fix,
after install will cannot connect to my sql by using PHP
you will see this error
"Fatal error: Call to undefined function mysql_connect() "
and looking in info.php
cannot see mysql...
------------------------------------------------------------------------
[2006-05-15 14:00:11] vktechnology at uk2 dot net
Because in PHP Makefile doesn't complatible with 64 Bits processor
64 Bits processor use "/usr/lib64"
instead of "/usr/local/lib"
***********************************
I found solution to fix this peoblem
now my problem is solved
***********************************
What i did is
after configure and open Makefile to edit Makefile
look example my configure
./configure --libdir=/usr/lib64 --prefix=/usr/local/php-5.1.4
--with-apxs2=/usr/local/apache2/bin/apxs --enable-ftp
--with-mysql-dir=/usr/local/mysql
--with-libxml-dir=/usr/local/libxml2-2.6.24
--with-png-dir=/usr/local/libpng-1.2.8-config
--with-zlib-dir=/usr/local/zlib-1.2.3/ --with-gd
--with-jpeg-dir=/usr/local/lib64/
--with-freetype-dir=/usr/local/freetype-2.2.1
open Makefile
find for
"/usr/local/lib"
and replace with "/usr/lib64"
*********
here this is code after replace
4 lines
EXTRA_LDFLAGS = -avoid-version -module -L/usr/lib64
-L/usr/local/zlib-1.2.3//lib
EXTRA_LDFLAGS_PROGRAM = -L/usr/lib64 -L/usr/local/zlib-1.2.3//lib
NATIVE_RPATHS = -Wl,-rpath,/usr/lib64
-Wl,-rpath,/usr/local/zlib-1.2.3//lib
PHP_LDFLAGS = -L/usr/lib64 -L/usr/local/zlib-1.2.3//lib
PHP_RPATHS = -R /usr/lib64 -R /usr/local/zlib-1.2.3//lib
********
type make
make install
..done...
------------------------------------------------------------------------
[2006-05-14 12:30:27] tony2001@php.net
And this is PHP problem because .... ?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/37427
--
Edit this bug report at http://bugs.php.net/?id=37427&edit=1