#37594 [Fbk->Opn]: mssql fails under load
| From: | mzamora at meritlending dot com | Date: | Tue, 30 May 2006 15:44:27 +0000 |
| Subject: | #37594 [Fbk->Opn]: mssql fails under load | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-97806@lists.php.net to get a copy of this message | ||
ID: 37594
User updated by: mzamora at meritlending dot com
Reported By: mzamora at meritlending dot com
-Status: Feedback
+Status: Open
Bug Type: MSSQL related
Operating System: windows 2000 sp4
PHP Version: 5.1.4
Assigned To: fmk
New Comment:
We have the server running with the php_dblib.dll, but because of the
long holiday weekend the server has not been under the load level that
causes the failure.
Previous Comments:
------------------------------------------------------------------------
[2006-05-26 06:24:02] derick@php.net
Let's leave at feedback until then then.
------------------------------------------------------------------------
[2006-05-26 00:13:40] mzamora at meritlending dot com
we are using php5apache2.dll. It will be some time tomorrow before I
get a chance to do any testing with php_dblib.dll.
------------------------------------------------------------------------
[2006-05-25 23:54:13] fmk@php.net
Are you using CGI or php5apache2.dll?
The library used by the mssql extension is not thread safe. You might
want to try php_dblib.dll. It's the same mssql_*() functions but it's
compiled against FreeTDS.
------------------------------------------------------------------------
[2006-05-25 23:42:43] mzamora at meritlending dot com
Description:
------------
Under heavy load the server responds with the following:
"Warning: mssql_pconnect() [function.mssql-pconnect]: Unable to connect
to server: servername"
We see the same type issue with the connect function.
Our configuration is as follows:
OS - Windows 2000 SP4
Apache - 2.0.0.58
PHP - 5.1.4
Changes to the PHP.ini include
Enabling the following extensions
extension=php_curl.dll
extension=php_mime_magic.dll
extension=php_mssql.dll
extension=php_openssl.dll
extension=php_printer.dll
All mssql relevant settings have been not been changed from
php.ini-dist
Please let me know what we can do to help find a resolution to this
issue.
As a note the issue we are encountering is exactly like the one
reported in bug #32854
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=37594&edit=1