#37877 [Opn->Bgs]: 255 char limit for SQL statements
| From: | tony2001@php.net | Date: | Thu, 22 Jun 2006 19:04:09 +0000 |
| Subject: | #37877 [Opn->Bgs]: 255 char limit for SQL statements | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-98679@lists.php.net to get a copy of this message | ||
ID: 37877
Updated by: tony2001@php.net
Reported By: jr at johnrule dot com
-Status: Open
+Status: Bogus
Bug Type: *Database Functions
Operating System: xp
PHP Version: 4.4.2
New Comment:
Duplicate of bug #37757.
Previous Comments:
------------------------------------------------------------------------
[2006-06-21 17:48:51] jr at johnrule dot com
Description:
------------
An 'INSERT' command with more than 255 characters will fail when using
COM and an ADODB.Connection (i.e. a direct connection to an access.mdb
file). However, the command will succeed if you connect through an ODBC
connection to the same file. This would prove that the limitation is not
a part of the file itself, but a part of the functionality of the
interface...wouldn't it?
I tested this on PHP 4 and 5 with the same results:
Apache 2
PHP (4 or 5)
Windows XP
Reproduce code:
---------------
Just try to do an 'INSERT' command with more than 255 characters in it.
It works on an Access.mdb file through a System DSN (ODBC) but it fails
when using COM and ADODB.Connection (i.e. a direct connection to the
file).
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=37877&edit=1