cvs: php-src / CODING_STANDARDS
| From: | Derick Rethans | Date: | Wed, 03 Dec 2003 09:12:39 +0000 |
| Subject: | cvs: php-src / CODING_STANDARDS | ||
| Groups: | php.cvs | ||
| Request: | Send a blank email to php-cvs+get-24859@lists.php.net to get a copy of this message | ||
derick Wed Dec 3 04:12:39 2003 EDT
Modified files:
/php-src CODING_STANDARDS
Log:
- I am sure I reverted this before
Index: php-src/CODING_STANDARDS
diff -u php-src/CODING_STANDARDS:1.26 php-src/CODING_STANDARDS:1.27
--- php-src/CODING_STANDARDS:1.26 Fri May 23 06:38:43 2003
+++ php-src/CODING_STANDARDS Wed Dec 3 04:12:38 2003
@@ -133,22 +133,7 @@
[5] Variable names should be in lowercase. Use underscores to separate
between words.
-[6] Method names follow the 'studlyCaps' (also referred to as 'bumpy case'
- or 'camel caps') naming convention, with care taken to minimize the
- letter count. The initial letter of the name is lowercase, and each
- letter that starts a new 'word' is capitalized.
-
- Good:
- 'connect()'
- 'getData()'
- 'buildSomeWidget()'
-
- Bad:
- 'get_Data()'
- 'buildsomewidget'
- 'getI()'
-
-[7] Classes should be given descriptive names. Avoid using abbreviations
+[6] Classes should be given descriptive names. Avoid using abbreviations
where possible. Each word in the class name should start with a capital
letter, with words underscore delimited. The class name should be prefixed
with the name of the 'parent set'.