cvs: win-installer / ExtensionsFragment.wxs GenExtensionsComponents.wxs.php

From: Date: Mon, 04 Aug 2008 14:59:30 +0000
Subject: cvs: win-installer / ExtensionsFragment.wxs GenExtensionsComponents.wxs.php
Groups: php.cvs 
Request: Send a blank email to php-cvs+get-51960@lists.php.net to get a copy of this message
jmertic Mon Aug 4 14:59:30 2008 UTC Modified files: /win-installer ExtensionsFragment.wxs GenExtensionsComponents.wxs.php Log: Bug #45091 - Fixed remaining issue with mibsdir during the build. http://cvs.php.net/viewvc.cgi/win-installer/ExtensionsFragment.wxs?r1=1.2&r2=1.3&diff_format=u Index: win-installer/ExtensionsFragment.wxs diff -u win-installer/ExtensionsFragment.wxs:1.2 win-installer/ExtensionsFragment.wxs:1.3 --- win-installer/ExtensionsFragment.wxs:1.2 Thu Jul 10 19:31:05 2008 +++ win-installer/ExtensionsFragment.wxs Mon Aug 4 14:59:30 2008 @@ -132,7 +132,6 @@ <File Id="mibsfile20" Name="IPV6-U_1.TXT" LongName="IPV6-UDP-MIB.txt" Source="Files\extras\mibs\IPV6-UDP-MIB.txt" /> <File Id="mibsfile21" Name="MTA-MIB.txt" Source="Files\extras\mibs\MTA-MIB.txt" /> <File Id="mibsfile22" Name="NETWOR_1.TXT" LongName="NETWORK-SERVICES-MIB.txt" Source="Files\extras\mibs\NETWORK-SERVICES-MIB.txt" /> - <File Id="mibsfile23" Name="output.txt" Source="Files\extras\mibs\output.txt" /> <File Id="mibsfile24" Name="RFC-1215.txt" Source="Files\extras\mibs\RFC-1215.txt" /> <File Id="mibsfile25" Name="RFC115_1.TXT" LongName="RFC1155-SMI.txt" Source="Files\extras\mibs\RFC1155-SMI.txt" /> <File Id="mibsfile26" Name="RFC121_1.TXT" LongName="RFC1213-MIB.txt" Source="Files\extras\mibs\RFC1213-MIB.txt" /> http://cvs.php.net/viewvc.cgi/win-installer/GenExtensionsComponents.wxs.php?r1=1.16&r2=1.17&diff_format=u Index: win-installer/GenExtensionsComponents.wxs.php diff -u win-installer/GenExtensionsComponents.wxs.php:1.16 win-installer/GenExtensionsComponents.wxs.php:1.17 --- win-installer/GenExtensionsComponents.wxs.php:1.16 Wed Apr 16 21:16:55 2008 +++ win-installer/GenExtensionsComponents.wxs.php Mon Aug 4 14:59:30 2008 @@ -137,7 +137,8 @@ $i = 0; $hasSeenMbString = false; while ( $i < $files->length ) { - if ( !is_file( realpath($files->item($i)->getAttribute('Source')) ) ) { + if ( !is_file( realpath($files->item($i)->getAttribute('Source')) ) + && $files->item($i)->parentNode->getAttribute('Id') != 'mibsdir' ) { $nodetoremove = $files->item($i)->parentNode; echo "Removing File " . $nodetoremove->getAttribute('Id') . " because " . realpath($files->item($i)->getAttribute('Source')) . " doesn't exist\n"; $files->item($i)->parentNode->parentNode->removeChild($nodetoremove); @@ -180,7 +181,7 @@ $nodetoremove = $componentRefs->item($i)->parentNode; echo "Removing Feature " . $nodetoremove->getAttribute('Id') . " because of missing Component $componentRefId\n"; $componentRefs->item($i)->parentNode->parentNode->removeChild($nodetoremove); - if ($i>0) $i--; + $i = 0; } $ExtensionsFeaturesWXS->save('ExtensionsFeaturesBuild.wxs');

« previous php.cvs (#51960) next »