Re: cvs: php4 /ext/sablot sablot.c
| From: | Andi Gutmans | Date: | Sat, 11 Aug 2001 00:15:38 +0000 |
| Subject: | Re: cvs: php4 /ext/sablot sablot.c | ||
| References: | 1 2 3 4 5 6 | Groups: | php.cvs |
| Request: | Send a blank email to php-cvs+get-6722@lists.php.net to get a copy of this message | ||
At 07:47 PM 8/10/2001 +0200, Thies C. Arntzen wrote:
On Fri, Aug 10, 2001 at 04:58:25PM +0300, Zeev Suraski wrote: Thies, You got it wrong. The engine provides services, on which modules are built. The data types, functions, etc. are all defined in the engine, using engine macros and names. PHP is one application that can be built on top of the engine, there are others. Obviously, the names to use are those of the engine, not PHP's. I'm changing the names so that they have different prefixes, but they'll all be defined in the engine, which is the right thing to do from a software development point of view.Thies, Relax. You're really being apocalyptic about a really dumb issue. Zeev just made the change because we thought it's dumb to duplicate code. I don't see why it doesn't make sense for PHP_FUNCTION() to be aliased to ZEND_FUNCTION() instead of duplicating the code. If the few people who debug really die from having the functions called zend_if_* when they debug instead of php_if_* we can think of some solution of having a parent macro which accepts a prefix. I have no problem with you preferring this if what really bothers you is the prefix. But please don't use such meaningless things just to pointlessly attack us. Andilets just rename PHP to Zend!thanx for listening:-(