Re: com php-src: Fixed warning of no return in non-void funciton: Zend/zend_vm_def.h Zend/zend_vm_execute.h Zend/zend_vm_gen.php

From: Date: Fri, 14 Dec 2012 10:03:19 +0000
Subject: Re: com php-src: Fixed warning of no return in non-void funciton: Zend/zend_vm_def.h Zend/zend_vm_execute.h Zend/zend_vm_gen.php
References: 1 2 3 4 5  Groups: php.cvs 
Request: Send a blank email to php-cvs+get-70729@lists.php.net to get a copy of this message
Hi! > a couple of compilers or analyzers are confused by this macro, not > sure why, but reducing the noises at no cost help to get a better view > in future checks. There is a cost - now we have both zend_error_noreturn and return statements, which is unneeded. If we say zend_error_noreturn does not work, we should remove it and use zend_error, and not complicate the code base. If we say zend_error_noreturn does work, then we should not add plugs after it. Having both zend_error_noreturn and plugs only makes code completely confusing and hard to read for everybody - why we have return after code that we marked as noreturn? Why we have special noreturn function if we have to use plugs anyway? -- Stanislav Malyshev, Software Architect SugarCRM: http://www.sugarcrm.com/ (408)454-6900 ext. 227

« previous php.cvs (#70729) next »