com php-src: Remove obsolete function names from CODING_STAND ARDS file: CODING_STANDARDS

From: Date: Tue, 25 Jul 2017 06:04:23 +0000
Subject: com php-src: Remove obsolete function names from CODING_STAND ARDS file: CODING_STANDARDS
Groups: php.cvs 
Request: Send a blank email to php-cvs+get-98792@lists.php.net to get a copy of this message
Commit: f469edcf59177f3004cba019fa143dbaaaeeaf6b Author: Aleš Rebec <alesrebec@gmail.com> Fri, 14 Apr 2017 22:26:50 +0200 Committer: Joe Watkins <krakjoe@php.net> Tue, 25 Jul 2017 07:04:23 +0100 Parents: 4ddb0630c216481dbc25605421551ad676c8c4f0 Branches: PHP-7.2 master Link: http://git.php.net/?p=php-src.git;a=commitdiff;h=f469edcf59177f3004cba019fa143dbaaaeeaf6b Log: Remove obsolete function names from CODING_STANDARDS file Deprecated and removed function names used as examples in coding standards file. - Mcrypt is deprecated and will be removed in 7.2 - Mysql functions are deprecated in 5.4 and removed in 7.0. According to those changes, CODING_STANDARDS file should be updated. Changed paths: M CODING_STANDARDS Diff: diff --git a/CODING_STANDARDS b/CODING_STANDARDS index 5cf70c9..38e5013 100644 --- a/CODING_STANDARDS +++ b/CODING_STANDARDS @@ -93,12 +93,12 @@ User Functions/Methods Naming Conventions readability of the function name itself:: Good: - 'mcrypt_enc_self_test' - 'mysql_list_fields' + 'str_word_count' + 'array_key_exists' Ok: - 'mcrypt_module_get_algo_supported_key_sizes' - (could be 'mcrypt_mod_get_algo_sup_key_sizes'?) + 'date_interval_create_from_date_string' + (could be 'date_intvl_create_from_date_str'?) 'get_html_translation_table' (could be 'html_get_trans_table'?)

« previous php.cvs (#98792) next »