Re: Persistent connection: Yes or Not?

From: Date: Fri, 20 Jul 2001 10:25:14 +0000
Subject: Re: Persistent connection: Yes or Not?
Groups: php.db 
Request: Send a blank email to php-db+get-10600@lists.php.net to get a copy of this message
This is only a guess but for Windows 2000, is there a file in your oracle directory called initxxxxxxxx.ora? The x's would be the instance name. You might have a maximum number of users defined in that file which is limiting your persistent connections. Check license max users (license_max_users) and license max sessions (license_max_sessions). You can also set license session warning (license_sessions_warning) which will give you a warning message when the number of connections is reached before a failure message is generated. If you dont' have this file, then check your oracle.reg file. In actuality, Oracle should not crash when it hits the max users. It should only return an error message. You might want to open up a problem report with Oracle or search their site for possible fixes. I haven't dealt with Windows 2000. My experience is with Solaris so I'm not sure if the setup is the same. I assume it is. Good luck! -----Original Message----- From: Ventsyslav Vassilev <wency@comelsoft.com> To: php-db@lists.php.net <php-db@lists.php.net> Date: Friday, July 20, 2001 3:55 AM Subject: [PHP-DB] Persistent connection: Yes or Not? >Recently i have faced the following issue: >I have a site running Apache 1.3.19 under Windows 2000 pro/PHP 4.0.6./Oracle >8i >After a little load Apache crashes with ORA-00020 error - maximum number of >Ora connections exceeded. This problem seems to be faced very often by other >people. Limit in ora.reg is 50, but the other told me that even value of 300 >does not resolve the issue. >After i started to use OCILogon() function instead of OCIPLogon() the >problem was solved and the site speed is not affected in any way. >But is this the correct way or...? > > >-- >________________________________ >Ventsyslav Vassilev >Comel Soft Multimedia >Sofia, Bulgaria >ICQ UIN: 11199819 >e-mail: wency@comelsoft.com >Visit http://www.comelsoft.com > > > >-- >PHP Database Mailing List (http://www.php.net/) >To unsubscribe, e-mail: php-db-unsubscribe@lists.php.net >For additional commands, e-mail: php-db-help@lists.php.net >To contact the list administrators, e-mail: php-list-admin@lists.php.net >

« previous php.db (#10600) next »