Re: Re: Oracle 9i Support

From: Date: Thu, 26 Jul 2001 21:18:14 +0000
Subject: Re: Re: Oracle 9i Support
References: 1 2 3 4 5 6 7 8  Groups: php.db 
Request: Send a blank email to php-db+get-10813@lists.php.net to get a copy of this message
Ok I'm a dumbass :) $ORACLE_HOME was set to mode 770. That seemed to fix the problem. I'll have to do some more stuff besides loging-on to the database to make sure all the functions work right though. When I get some time I'll send you those patches for configure and configure.m4. In the meantime making a libclntsh.so.8.0 a symlink to libclntsh.so.9.0 will work. Thanks. -Lee "Thies C. Arntzen" wrote: > > On Thu, Jul 26, 2001 at 02:21:02PM -0500, Lee Whatley (System Admin) wrote: > > > > If I try to use ocilogon("scott","tiger"); I get the following: > > Warning: _oci_open_server: Error while trying to retrieve text for error > > ORA-12546 > > > > If its giving me an ORA-12546 error then I am assuming it is at least > > trying to talk to the database. I guess it must be a library > > incompatibility issue. > > no - > > 12546, 00000, "TNS:permission denied" > // *Cause: User has insufficient privileges to perform the > // requested operation. > // *Action: Acquire necessary privileges and try again. > > please make sure that the user that runs apache can actually > access $ORACLE_HOME and all needed files withing! > > tc > > > > > "Thies C. Arntzen" wrote: > > > if phpinfo says oci8 is included than it _is_. the libraries > > > used thing might (and probably is) broken. just try calling > > > ocilogon($user,$pw); and see what it does! > > > > > > tc

« previous php.db (#10813) next »