Nedd urgent help with PHP 4.1.0, IIS5 Windows 2000, Oracle 8.1.6, OCIPlogon

From: Date: Thu, 20 Dec 2001 08:45:12 +0000
Subject: Nedd urgent help with PHP 4.1.0, IIS5 Windows 2000, Oracle 8.1.6, OCIPlogon
Groups: php.db 
Request: Send a blank email to php-db+get-15135@lists.php.net to get a copy of this message
Hello, I have a strange problem, i nedd to use php under IIS for accessing Oracle database I'm using OCIPlogon to connect to Oracle because i need the fastest possible response. When i use a small script with OCIPLogon OCIParse OCIexecute OCIFetchStatement OCIFreeStatement (OCILogoff) - i understand this is not necessary anymore. ??? all things is running/working OK, but when for some reson i need to restart the Oracle service the next time the script is executed, return an error message, the message from OCIError is : code = 12571 message = ORA-12571: TNS:packet writer failure Warning: failed to rollback outstanding transactions!: ORA-03114: not connected to ORACLE in Unknown on line 0, but if i use Apache in place of IIS, this thing is working OK, but with Apache at least with php 4.0.6 i has some another strange problem : the number of open session to oracle is increased rapidly and the script is stopped working, ata the moment i don't have time to try this with php 4.1.0. Any help would be appreciated, Thank you JSz.

« previous php.db (#15135) next »