FW: [PHP-DB] Solved!--But Query Optimization for many-to-many tab les (fwd)

From: Date: Wed, 26 Jul 2000 14:30:12 +0000
Subject: FW: [PHP-DB] Solved!--But Query Optimization for many-to-many tab les (fwd)
Groups: php.db 
Request: Send a blank email to php-db+get-1518@lists.php.net to get a copy of this message
On Wed, 26 Jul 2000, Foley, John wrote: > Beware of table names (or column, ets) like 'Join' . . . it is an > SQL reserved word and may behave very differently in diferent RDBMS's John's right. I used 'Join' in my suggestion as a sort of generic name to indicate that it was a join table. In addition to the problem that John mentions, there's the problem that occurs when you have many tables, and you haven't looked at the tables in months, and now you have to do some maintanence. Which two tables does Join join? You won't have a clue. A better name would be something like products_to_types, or better, products_join_types, which has the advantage of saying that it is a join table. > The geographical center of Boston is in Roxbury. Due north of > the center we find the South End. This is not to be confused with South > Boston which lies directly east from the South End. North of the South > End is East Boston and southwest of East Boston is the North End. If you understand that, you're overqualified for this mail list. Bob Hall

« previous php.db (#1518) next »